Fixing crashes during CAS
#1 08-12-2017 
  • Registered
  • 1
  • 3
Hey errybody.

I've been perusing the internet for a few hours on how to fix my crashing issue. I just installed Sims 2 (well, okay, it's my THIRD try...) from DVDs to my Windows 10 laptop. The first thing I do when the game loads and puts me in the neighborhood is change my resolution. It works until I get to CAS; when I try to change the hair on my female sims, the game crashes. I've looked at my config-log and noticed my video card isn't found.

I've tried to edit the Video Card.sgr file, but I can't open it. I tried changing it to .txt, editting it (adding: card 0x0116 "Intel® HD Graphics 3000"), then back to .sgr, but then it gave me an error about Direct 9x something or other. I also tried to download the RAR files that Kiri had posted, but my program wasn't letting me un-rar them. (Hence my just trying to figure out how to insert the text.)

I've reinstalled the game and want to give editting the Video Card.sgr file another go, but I'm not sure how to open it or edit it. Any clues? (Things I've tried: unhiding extensions for known file types and trying to set associations for file extensions but .sgr does not show up.) Wasn't sure if there was a safe program to download or what-not. After googling for a bit, I couldn't find anything that looked reliable.

Also, I'm hoping to install University and Night Life, and I understand I will have to update the Video Card.sgr in BOTH of those file pathways. So hopefully after fixing this I can just copy paste the file into both Univ and NL.

Hoping to fix this issue before I lose brain cells from hitting my head against the wall. Confused Dodgy Blush Thanks for the help!

P.S. After my latest re-install, I didn't change the resolution, changed hair color, went out, changed resolution and then I was able to change hair color. But the video card is still not found in the database. So...weird, right?? The problem isn't solved though, right?? Am I going crazy? I think I'm going crazy. Huh

Attached File(s)
.txt  DESKTOP-EUIGB87-config-log.txt (Size: 7.81 KB / Downloads: 362)

#2 08-12-2017 
  • Registered
  • 1
  • 3
Okay, I figured out how to edit it, and it's changed, but it's still not registering in my log. ?? I was able to CAS a couple of times, but it just crashed again. Thanksssss.

AWW YEA! I did it! I added it to both the config and csconfig folders.

Wow guys. Don't mind me. Just having a conversation with myself here. Sorry about that.........

Blush Angel

Attached File(s) Thumbnail(s)

.txt  DESKTOP-EUIGB87-config-log.txt (Size: 8.37 KB / Downloads: 342)
(This post was last modified: 08-12-2017 06:57 AM by seegie.)

#3 08-12-2017 
  • Registered
  • 1
  • 3
I got all my expansions installed and running smoothly. THANK YOU GUYS SO MUCH FOR THIS FORUM and your big smart brains!!!!!! Heart Heart Heart Heart Heart Heart Heart

#4 08-12-2017 

Sorry that I wasn't around to help you with this - I'm not doing very well mental health wise, so it's been a while since I have an attention span worth mentioning.

Glad to see that you got it working.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option