The Sims 2 Ultimate Collection Crashing When Selecting Neighborhood
#1 29-12-2017 
Hi there, I posted this on another site yesterday though no response yet and I figured it couldn't do much harm to seek help here as well.

I hadn't played the game in a few months and when starting it up yesterday, it first started up a bit different than normal (a blue box appeared with a white outline on my desktop before the application opened, which it's never done) then after the initial loading screen I got that, "Ts2 has stopped working" dialogue before the game closed. I've tried a lot of different things, all of which haven't helped much other than just giving me a different variation of errors.

I tried deleting the cache and neighborhood manager files (I haven't opened bodyshop), reinstalling the game, removing all CC, disabling my antivirus software, running as administrator, troubleshooting compatibility, reinstalling origin, and downloading the Graphic Rules Maker program to try and have it recognize my graphics card properly if that was/is the issue.
The variations of errors include: The "this program will now terminate" box with the red "x", just closing without warning, and what I mentioned before about the "Ts2 has stopped working" box before it closes.

I hope someone can help and thank you so much for your time. Heart

Attached File(s)
.txt  DESKTOP-CNA3R7F-config-log.txt (Size: 10.28 KB / Downloads: 592)
(This post was last modified: 29-12-2017 07:05 PM by pixelchixel.)

#2 30-12-2017 
I'm not sure that this would fix everything, but I've identified that your game at least suffers from the 32MB Texture Memory bug. To fix that bug, you would need to do the following:

Right-click on your desktop, and select "NVIDIA control panel". In bottom left corner of the panel, click the link "System Information". Then, in the next window, find the line "Dedicated Video Memory" and write down the number on that line.

Now, go into the folder "\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\Config\", and open the file Graphics Rules.sgr. Somewhere in the first 60 lines, there should be a line reading
"seti textureMemory 32". Change the "32" to read the number that you just wrote down.
Save the file and copy it to the folder "\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\CsConfig\"

If you couldn't find a line saying "seti textureMemory 32", you can ADD such a line (with the correct number, of course) just before the section named "Identify gfx device".
If you delete the cache files and restart the game, a new [xxxx]-config-log.txt will be created that shows the right number, confirming that at least THAT aspect of your settings is now fixed.

This will probably not fix the greater issue of the crashes (yet), but it might if we're lucky. If not, then you would need @celebkiriedhel's assistance for that. Let's hope she comes around again soon... Many people are awaiting her help.

#3 01-01-2018 
Hi again and happy new year!

Thank you so much for your help with that, however now I have a new problem, though the other one seems to be resolved so thank you so much for that! The new issue is that whenever I go to either load a family or click the create-a-sim/family tab (the tab that you can also select a family to place through) it immediately crashes without warning. Do you know if that's a common problem with a hopefully easy solution?

Thank you so much again for all your help!
EDIT: I managed to narrow the issue down to the game being unable to recognize my audio driver. Do you know a way I can go about fixing that? At least, I think that's the issue. I'm probably completely wrong but it seems like all errors point back to it? Probably wrong. I attached my new config-log!

Attached File(s)
.txt  DESKTOP-CNA3R7F-config-log.txt (Size: 10.28 KB / Downloads: 522)
(This post was last modified: 01-01-2018 09:07 PM by pixelchixel.)

#4 01-01-2018 
Happy New Year, @pixelchixel,

At least, your new config-log.txt confirms that the game now recognizes more texture memory. But it doesn't seem like your situation has improved much, does it? On the contrary, even.
With the new settings, does it also crash if you play without any CC?

My game doesn't recognize my audio driver either, but it still runs properly and I have sound while playing. So I'm not certain if the sound drivers not being recognized is actually a real problem. I think as long as Direct-3D can find your sound system, the game will happily accept that everything is fine in that department.
But I must admit that I'm out of my element here; I could be horribly mistaken.

#5 02-01-2018 
Yes, unfortunately, it does crash without CC. I thought for sure that might've been the problem but it seems that even with brand new files it still has this problem. At the moment I'm doing a fresh install of Origin and the game again just to see if that helps at all.

I appreciate all your help, and I realize now it was a bit silly to assume it was audio (wishful thinking that it may be something fairly obvious). Thank you again, and although I'm not sure that it'll do much I am in queue to talk to EA tech support on the phone again.

Edit: I spoke to tech support and they told me to do the usual update + repair and go in without touching anything else...which actually worked! It was when I edited graphic rules to have my preferred resolution be available that I started running into all the usual issues. Same thing happened when I used Graphic Rules Maker, so I wonder if I'll just be unable to play in 1920x1080? I'm sorry for dragging this out, I really do appreciate your help and I don't want to overstay my welcome if that makes sense.
(This post was last modified: 02-01-2018 06:21 AM by pixelchixel.)

#6 02-01-2018 
Ah, I think that explains something, although I'm not yet sure what exactly. Maybe we can get things set up without the Graphic Rules Maker, and thus avoid whatever it is that goes wrong.

What is your screen's native maximum resolution?

#7 02-01-2018 
@pixelchixel @BoilingOil

Thanks for your help BO.
In the Config-log.txt you can see what the native resolution is from these lines - they're under the Graphics Device Info part of the log. That comes from the system, not the game.

Monitor: \\.\DISPLAY1
Monitor aspect: 1.778156, 16:9
Screen mode: 1920x1080x32BPP,60Hz

When the game is low resolution, it's maximum is 800x600. However even in high resolution, it doesn't have 1920x1080 because widescreens weren't a thing back when the game was made so 1600x1200 is hard coded as the highest ratio. Fortunately, you can change the max resolution and it works fine.

Sometimes Graphics Rules Maker doesn't work well, fortunately we do know that these cards will pick up where the GRM fails, because we make them work! Smile

Lets start with fixing your cards -

Graphic Rules - NVIDIA - Texture Fix - Max Screen size 1920x1080
Video Cards.sgr - NVIDIA - 1b80

Install them into these folders:
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\Config\
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\CsConfig\

Then go back into the game (or let it crash) and post up the config-log.txt .

Also - do you have the latest updated version of Ultimate Collection? That can be a problem, because even though it removed securom it added some new problems. To turn off the updates please use the No_CD version of Sims2EP9.exe which I have uploaded here.
This is the version I have used for the last number of years so I can guarantee that it doesn't have viruses, and it works with the game fine.

This will stop UC from updating and remove most of the troubles that the new UC caused.

Once we know these work - we can update the texture memory from the dxdiag.txt to reflect your actual display memory.

#8 03-01-2018 
Thank you so much for responding, celebkiriedhel, and I hope you're feeling better! Also thank you so much for all your help, boilingoil, I would've given up days ago if it weren't for you.

I've installed the graphic rules you posted, though the video cards file sent me to a 404 error, and lastly I do have it updated so I downloaded the last No_CD version of Sims2ep9.exe file but it brings up an error when I try to run it, which I'll try to post here if I can. I'll also include my new config file. Thank you so much for this, I've gotten further than ever before! I actually got into Create-A-Sim and was messing around with different sliders, etc. before it eventually crashed. That's the longest it's stayed open in quite a while. I can't thank both of you enough for your help and patience.

Edit: I saw your response in another thread, celebkiriedhel, and it helped me with the two questions I had! I just wanted to let you know so you don't need to take the time to respond here and you can help others instead, etc. I appreciate all the help from the both of you and I'm so happy that the problems seemed to be fixed now. Thank you so so much! I'm so appreciative, I wish I could give you both something.

One thing though: if I did ever want to go about getting a larger monitor, is there a graphic rules for that as well?

Attached File(s)
.txt  DESKTOP-CNA3R7F-config-log.txt (Size: 10.4 KB / Downloads: 499)
(This post was last modified: 07-01-2018 05:55 PM by pixelchixel.)

#9 10-01-2018 
I'm so sorry to bother the two of you again but I seem to be having one last problem with the game. When I go into create-a-sim everything is fine for about two minutes before the program closes itself and I'm unsure why. I really appreciate both of your help and I feel just awful asking for help again but I think if I know what the issue here is then everything else will be/has been absolutely fine. Thank you so much!

Attached File(s)
.txt  DESKTOP-CNA3R7F-config-log.txt (Size: 10.38 KB / Downloads: 475)

#10 10-01-2018 
As far as *I* can see, @pixelchixel, and assuming that you *did* copy the .sgr files properly from the "\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\Config\" folder to the "\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\CSConfig\" folder, your graphics settings are most certainly *not* the cause of the problem.

So I think something else must be going on:

1. Simplest scenario: your cigen.package file has gotten corrupted. Cigen.package is found in the same place as the .cache files, and it performs a similar function. But whereas the .cache files belong to the game itself, the cigen.package belongs to CAS and BodyShop. Just like the .cache files, this can get corrupted and then causes crashes or failures to run. And the remedy is the same, too: delete the cigen.package before starting up. It will be re-created when necessary.

2. You could have some broken or corrupted skins, outfits, hairs or makeup in your Downloads folder. Finding and removing those would help, but this is a long-winded, tedious process.

3. You may have played around with the BodyShop, and some unfinished project gets in the way, or got corrupted. I'm not sure if this might really be relevant, but I'll just throw it out there. Maybe someone else can prove or disprove this idea.

At least, these are *my* views on the subject. I hope that some of this may help you. And if not, then hopefully someone else has a better idea.
Good luck.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option