Sims 2 UC Direct3D error crash
#1 15-01-2018 
  • Registered
  • 0
  • 1

I have been trying the listed fixes, including updating Nvidia drivers (could not get the one listed in the video as it is not compatible with my OS version) and updating the .sgr files.

My game worked once today, crashed while editing lots in a new neighborhood, and now will no longer open.

I get the following error each time:

Direct 3D returned an error: E_INVALIDARG!

I am running Windows 10 Home - Oh, how I wish my hubby had never upgraded me to 10....


Please let me know if the exception log from the time it ran and crashed would be helpful also.

.txt  STEPH-config-log.txt (Size: 10.41 KB / Downloads: 430)

ETA: I was not smart enough to save a copy of the exception log before trying the last-resort solution of uninstall/reinstall, so I cannot provide that now, sorry. And sadly, the problem is still not fixed.

ETA2: Found a workaround of steering to my integrated graphics card instead of through my NVidia card and my game runs that way- maybe just need to wait for a compatible driver that works again with both the game and my OS?
(This post was last modified: 17-01-2018 08:33 AM by mc57350.)

#2 04-02-2018 
@mc57350 - sorry for the late answer, but I just noticed your thread and I've been studying DirectX errors lately.

First thing to do with all DirectX (Direct 3D is part of it) errors is to run DxDiag. You can do it by pressing Win+R and then type DxDiag and press enter. The DirectX Diagnostic tool should open.

The first tag which opens doesn't help you much, but the second tag called "Display" is quite useful. First check the notes. Does it say that No problems found? If not, DxDiag should give you the option of repairing the problems it found.

Even if it says "Not problems found" you should check some other things from here. Are all DirectX features enabled? Does it identify your DDI version (if it doesn't it says it's unknown)? If some of the DirectX features are listed disabled or/and DxDiag doesn't recognize the DDI version, the most common reason is that your Nvidia drivers are not up to date. So double check which version of drivers you're using.

If any of this doesn't help consider trying program called DxWnd. It actually should help with some of the DirectX problems. You can find the link for the download page of the program from here and instructions how to use it with The Sims 2 from here. But you should first try running DxDiag. D3D is not supposed to give any errors at the first hand.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option