Sims 2 UC Flashing Purple
#1 22-01-2018 
  • Registered
  • 0
  • 2
Hi, I had the sims 2 UC installed on my computer and working perfectly. I stopped playing it for around 6 months and now that I've come back to it I can't seem to make it work. I had to reinstall the game due to crashes and since doing so my items in hood view are flashing purple. I tried rolling back my graphics driver as I know that's the only thing that is definitely different. Any help is greatly appreciated.

Attached File(s)
.txt  DESKTOP-AIQI0GN-config-log.txt (Size: 14.92 KB / Downloads: 431)
.txt  DxDiag.txt (Size: 88.32 KB / Downloads: 426)

#2 22-01-2018 
MooMoo, I notice you have Windows 10 Home 64 bit update version 1709, same as me and gwynne. Some folks have been having trouble with 1709 since mid-January, although maybe only the Pro version, not the Home version. Looks like you have Fun With Pets, are you playing the Ultimate Collection from Origin or using a noCD executable? Or from CDs?
[edit] Did you update your UC game through Origin recently? Some folks report trouble with the update that got rid of securom but may have introduced crashiness. For me, I have UC with the update, I play from Origin, and consistently crash on community lots after minutes of playing (several sim hours). If I try using the noCD exe that Kiri links to, I get pink/purple flashies. Removing cache files and everything from Thumbnails sometimes gets rid of the purple flashies when using the noCD exe but the noCD exe crashes when playing even faster than the Origin exe, for me.

Your 1070 GTX is recognized and your texture memory looks fine. Your HW programmable is at 3 like it should be. I'm guessing not an sgr issue then.

When you rolled back your driver, did you use Guru3d driver uninstall (DDU)? Then reboot and manually do a custom install w/ clean install of the driver? Instructions in this video that Kiri linked here. You may want to try an older nvidia driver circa 37x.xx or so but it may or may not help.

The one thing I have seen on the threads here and at MTS so far that did for sure fix it is restoring Windows back to 1703 but you lose stuff, it's drastic, and temporary because it will update itself again unless you disconnect permanently from the internet. Then again, others have 1709 and nvidia cards and Origin UC with the Origin update and it works fine for them, lucky folks.

You may want to see possibly similar threads about January 1709/nvidia/UC issues here and here but you may or may not have a similar issue. See the posts from today/yesterday where gwynne confirmed 1703 does let it work again. Your issue could be different.

#3 23-01-2018 
  • Registered
  • 0
  • 2
Hi yeah, its UC with the noCD. I recall it automatically updating not long ago, it had initially been crashing just before allowing me to select a hood but that seems to be fixed after reinstalling the game however I have not tried live mode yet. Using the Origin exe makes no difference for me.

I have done what you suggested with the NVidia drivers and its made no change unfortunately.

Looks like the only way I can play my game is to restore Windows which is problematic as I updated in October so would need to use the iso and have no usb to do so. So frustrating!

Thanks anyway


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option