Suddenly pink flashing game with Windows 10
#1 24-01-2018 
Hello, I am sorry to add to the list of "my game is suddenly going crazy on Windows 10" game is suddenly going crazy Sad

I have the Sims 2 Ultimate Collection and I have not updated to the latest patched version through Origin. I have patched my .exe file with the CFF Explorer so that my game can read up to 4gigs of RAM. My OS is Windows 10 Home.

To be specific about my issue, I have been playing my Sims 2 neighborhood for over a year, never had any issues with it. I have been busy for the past 3 months or so, so I've only had to time to check in periodically but not to play. It all seemed to be fine at a glance until I tried to play a couple of weeks ago and found a flashing pink mess when I tried to load the game. I tried to delay it for as long as possible, but I did have to let the mandatory Windows 10 update go through a few weeks back. I also have updated the Nvidia drivers to the most recent. I tried rolling those back to see if that was the problem, but it would only let me go back a couple of updates before telling me that the rollbacks I wanted would no longer be compatible with my version of Windows and I saw no improvement. I also can't roll back Windows directly because I don't have System Restore enabled on this computer. I have tried removing all CC from the game and that also made no difference with the flashing.

I thought that it must have been my GPU going bad for a while, so I ran it through several benchmarks, but it really does seem to be healthy and it failing doesn't seem like a likelihood.

I have been scouring these boards and watching the video on pink flashing and reading all the threads about people having issues with Windows 10 specifically. I feel as though I've tried just about everything and I no longer know what else to try so I figured it would be the right time to just ask directly. It's a pretty depressing situation. Would going back to Windows 8 be of any help whatsoever?

I've attached my DxDiag, Config Log and the Sims2Exception file from the latest pink-induced crash as well as a picture of the 'hood itself.

Thanks in advance.

Attached File(s) Thumbnail(s)

.txt  FITZWILLIAM-config-log.txt (Size: 15.12 KB / Downloads: 471)
.txt  DxDiag.txt (Size: 89.45 KB / Downloads: 552)
.txt  Sims2Exception 2018.01.23 19.23.00.txt (Size: 13.26 KB / Downloads: 554)
(This post was last modified: 25-01-2018 02:49 PM by mortia.)

#2 24-01-2018 
Welcome to the 'my sims game is broken on Win 10' club! Have a Gold Llama of Frustration pin! Let me take a look at your files and see if anything jumps out at me. Would it help to say I haven't found anything yet to make my game work? Probably not. Sorry. At least you know it's not just you. Wink Can you please let us know what you have tried so far? nevermind, you did post what you already tried. I'll post anything I find in a moment...

Ok, looking at your config log, I see it recognizes your card, finds it in video cards sgr, and Programmable is at 3, that's all good. Your texture memory is set to 1744 which is the value from Kiri's texture fix graphics rules sgr. I bet you can do higher. Let's look at your dxdiag... In your dxdiag, under Display Devices, I see your dedicated memory is 4053 mb so let's change your graphics rules sgr. Wherever you see

seti textureMemory 1744

change it to

seti textureMemory 4053


You may have done this already. Your graphics driver is up to date, version 390.65. However, Windows 1709 does bork the way it installs drivers. An uninstall and clean reinstall may help. Do NOT use GeForce Experience to do this. Instead, use DDU and manually install the driver after rebooting, then reboot again. Instructions here:
oops let me find the right link


That's all I can think of right now. May try changing NVidia settings in NVidia Panel, less quality, more performance. I haven't tried that yet.
(This post was last modified: 24-01-2018 11:33 PM by CatOfEvilGeniu.)

#3 24-01-2018 
see previous post
And finally, here's this pink flashy video from Epi7's thread, you may have seen it already.

nevermind, you did watch that video already

#4 24-01-2018 
@CatOfEvilGeniu, thanks for the welcome to the worst club ever! Rofl

I started by just googling "Sims 2 Pink Flashing" which led me to a bunch of older topics on various sites, as well as the aforementioned video, but I paid special attention to this thread here by @Epi7 since it was very recent and seemed very familiar. I have tried everything in that thread. Though my latest posting of GraphicRules doesn't show it, I have also tried to manually increase my texture memory to match what it says on my DXDiag (4053). I just last night switched out the GraphicRules that had been generated by the program that's out there with the ones from this site instead. I have deleted the Thumbnails numerous times and the latest experiment was changing # never trust the driver to manage its own memory from "false" to "true". I have run the game in various Compatibility Modes, tried turning down settings, doing the 50/50 method...still pink for days.

I have tried going into other 'hoods to see if it's a game-wide issue, but it seems to be focused on that one hood. No doubt because that's where I am using all of my CC. Of note, however, is that I made a clean hood a couple of weeks ago for picture-taking purposes, and when I went to move in the test family, they were showing on the household screen in pink t-poses. That was my first time seeing that and it shocked me as the hood was quite literally empty. I have since seen that same thing happen in my main hood, but that it also happened in an empty hood has confused me.

Thanks for all of your help!

Ooh, you added some stuff while I was typing! I will try the manual uninstall/reinstall of the NVidia drivers next Smile

ETA Adding photo for pink CAS stuff reference.

Attached File(s) Thumbnail(s)

#5 25-01-2018 
I've tried updating the sgr to allow the driver to manage its own memory and have updated my "seti texture memory" wherever I found it to be 4053. Can anyone check this new file and let me know if I did it correctly? Thanks!

Attached File(s)
.rar  Graphics Rules.rar (Size: 7.22 KB / Downloads: 556)

#6 25-01-2018 
The real test would be if you ran the game once, and then uploaded the newest config-log.txt. But I've checked and it *seems* to be in order. At least, if you edited only the one line, then it's OK.

But I wonder, if the driver is allowed to manage its own memory, would it not simply ignore whatever value you set in Graphics Rules.sgr? And if so, would it not be pointless to change that file as well? But that's just an old man rambling, of course! Big Grin

#7 25-01-2018 
@BoilingOil - I'm hoping that if the driver is allowed to manage its own memory, it will use the max it can rather than having some limitations imposed on it by UC that were made when graphics cards were older. It did make a difference on my machine. This change to the sgr allowed my noCD exe with the 4gb patch to finally run without crashing. I suspect a combination of factors, clean install of the driver, modified sgr, and allowing the driver to manage itself is what finally did it. The clean install and modified sgr (without allowing the driver to manage its memory) did not allow me to run without crashing. I could test an sgr where driver autonomy is the only change and see if it does really ignore everything else in there, but I suspect the other change may be needed. Not planning to do that test right now, trying some other things first, but it would be an interesting test.

@mortia - Did you copy the new sgr over to Config and CSConfig and run your game again?

#8 25-01-2018 
@BoilingOil, thanks for checking that for me!

@CatOfEvilGeniu, I had to turn up to the office for the daily grind, so I haven't had a chance yet but I will update as soon as I get home. I didn't even remember that I needed to meddle with things in CSConfig as well. I also remembered that I had an old laptop with Windows 8 on it, so if all else fails (and it even powers up) I want to try an install of the game on there and see if the game backups I made will work properly. If using an older OS solves this issue, then I have no issues with going back to 8, or even 7!

I will post an update later! Thanks again!

#9 26-01-2018 
@CatOfEvilGeniu I'm quite certain that I did not explain it well, because I'm getting the impression that I did not properly get my point across. So please bear with me while I try to be more verbose and explicit, and hopefully also more clear and helpful!

My idea is to ONLY make the setting that allows the driver to manage memory autonomously, and see if that will work properly without us touching the "seti textureMemory ####" setting. If all is well, after running TS2 just once, the config-log.txt should tell us how much texture memory the game was told to be available regardless of the textureMemory setting in Graphics Rules.sgr. And ofcourse, if I am right that it will ignore the setting in Graphics Rules.sgr, then the only reasonable assumption would be that it will indeed use the maximum available memory. Because if it did not, then there would be no point in using this autonomous setting, would there?

The other alternative - editing the "seti textureMemory ####" line directly and NOT allowing the driver to manage memory - was already done, and we known that either it works or it does not.
If it does not work properly, we do not exactly know why. But when it does work, we cannot be certain that we gave it really all the memory that it could access on its own. After all, we only have the report from dxdiag or, - in case of an nVidia card - the nVidia control panel. And we don't know that either of those tell us the entire story of what the card/driver can precisely use.

Either way, nothing is stoppping me from trying this idea out on my own system, even though that already works sufficiently well for me. So that's what I'm going to do first, now. Big Grin

EDIT: OK, that did NOT end well!

1. I set "boolProp enableDriverMemoryManager true", and - just to screw with the system so as to know for sure - set the textureMemory line to 32MB. I started the game, and you know what happens? It decides that because of too little memory, it needs to revert to the 800x600 resolution and all low graphic quality settings.

2. Then, for comparison, I totally removed the "seti textureMemory ####" line, hoping that the system would notice and actually get accurate readings from the driver... No such luck; again an 800x600 game with poor graphical quality.

The driver could obviously NOT be trusted to figure out for itself how much memory is there, and I have an nVidia GeForce GTX 1050 Ti (4GB)!
So, apparently, having "seti textureMemory 4096" and not relying on the driver to manage its memory is the best way for me to go. At least that way I can just play at 1920x1200 resolution with all settings at maximum!

But then, of course, one has to remember that I'm running on W7, NOT W10!

I hope this helps.

#10 26-01-2018 
@BoilingOil - You were clear and it was a good experiment, interesting data. I suspect, however, that ‘manage memory’ may be more than, or be something other than, only figuring out how much memory is available. Would write more but need to get to work! Back later and thank you


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option