The Sims 2 (Non-UC) Flashes Pink & Crashes Constantly on Windows 10, GTX 1060
#1 24-02-2018 

I was naive to think that my new gaming laptop (I7 7700HQ 2.8GHZ, 16 GB RAM, GTX 1060 on Windows 10) was going to allow me to play The Sims 2 like never before. Well, now I can't play at all!

The problem is flashing pink both in-lot and on the neighborhood screen, and *very* frequent crashes. It's practically impossible to play.
I am not playing UC, but I have all the expansion and stuff packs installed separately. So I launch the game from Sims2EP9.exe (Mansion and Garden Stuff)

What I have tried so far:

-Allowing the app to use more than 2 GB RAM through CFF explorer.
-Did the 4 GB patch.
-Did the data execution prevention exclusion.
-Updated the directX.
-Tried to let Graphic Rules Maker do its magic.
-When that did not work, edited the Graphic Rules.sgr myself:
*to allow high resolution
*to allow texture memory the same as my Dxdiag states (6061 MB)
-I made the game start in windowed mode by adding -w to the shortcut
-To tackle possible multi-core problems I set the affinity of the game to one core.
-My anti-alias is on.
-I introduced my graphics card to the Video Cards.sgr file
-Using an empty Groups cache file did delay the crash only for a little while.
-When the game started crashing while loading the neighborhood, deleting the NeighborhoodManager before starting the game allowed me to load the neighborhood. But after a while it will definitely flash purple.

When I try to run the game in compatilibity mode and as the administrator, I get the directx error.
When I try to start Graphic Rules Maker as the administrator, it "Cannot find Graphic Rules files." but when I run it normally it immediately does find them, yet I'm not sure if then it successfully makes all the changes.

I have 12 GB of CC in my downloads folder; but I have played the game with almost twice this size CC on my old, windows 7 computer without a problem for many years.
Downgrading from Windows 10 to Windows 7 is also not an option, since I don't want to risk removing drivers that I may not be able to find compatible with Windows 7. Such a downgrade probably would be very problematic; since the laptop was shipped with Windows 10.

I may have tried many other things that I might have forgotten to mention here... Still pink flashes, still crashing. I'm still willing to try many other solutions. Sims 2 is quite important to me and it's saddening that it's almost becoming one of those old games that aren't playable anymore due to their incompatilibity with newer systems. I really hope there is a solution for this.
For now, the problem seems to be a texture memory issue and how the game handles it with my NVIDIA GTX 1060 graphics card and Windows 10. It feels like there should be specific tweaks to allow them to work harmoniously together; but spotting that tweak seems to be too advanced for me! I just can't point where exactly the problem is.

Could anyone help me further with it?
Thanks in advance!

Attached File(s)
.txt  LAPTOP-RP7UKD1I-config-log.txt (Size: 10.25 KB / Downloads: 503)
.txt  Graphics Rules.sgr.txt (Size: 33.31 KB / Downloads: 498)
.txt  Video Cards.sgr.txt (Size: 26.74 KB / Downloads: 487)

#2 24-02-2018 
@mrukel22 - Try turning compatibility mode OFF and do not use CPU core throttling. Several of us have found that compatibility mode seems to break things rather than helping. We have gotten the game to run well for days without crashing by doing what you said but NOT using compatibility mode.

You should not need to do anything with data execution prevention settings, try putting them back the way they were.

Your config log files looks good.

Finally, did you do a graphics driver manual clean install? Not with GeForce Experience. Not through Windows.
Turn off driver updates in GeForce Experience, turn off driver updates in Windows, then use guru3d DDU to uninstall the driver.
Download the right one from and manually do a custom install, clean install.

Let us know if that helps, good luck! I think despite Win 10 1709 breaking things, we may be able to get our games to a playable state after much hair pulling. Wink

#3 24-02-2018 
Thanks for your reply CatOfEvilGeniu!

I turned the compatibility mode off, stopped CPU core throttling and put the data execution prevention settings back to its original state. I used guru3d DDU to uninstall my NVIDIA driver and then downloading the right driver I did a clean install.

Unfortunately game crashed yet again; and although not as bad as before, pink flashes appeared too.
I use "Gunmod's Radiance Light System 2.5.1: Now with 100% Less Blue Nights + Fixed Seasonal Borkage", and I noticed that the biggest pink flash occured when it was around 6 AM in-lot, during the orange light of sunrise. As soon as it went back to normal daylight, most of the flashes disappeared. Does that mean the whole issue is related to lighting in some way? Even if so, doesn't it mean it's still about texture memory?

This issue has been consuming my DAYS, dimming my joy for the new laptop haha. I even considered downgrading to Windows 7 but found out that Omen by HP 15 doesn't have drivers compatible with Windows 7; most are only Windows 10 and some Windows 8.1 so it seems I'm stuck in this Windows 10 hell, unable to play TS2. Glare

#4 25-02-2018 
  • Registered
  • 0
  • 6
I experienced this too yesterday after I updated my graphic card from Geforce Experience Express install. (I used GTX 1060 6GB on Windows 10 too)
I immediately uninstall the driver from device manager and re-install from my driver cd that i got from the manufacturer
Thank god the pink flicker gone. I used NVidia geforce gtx 1060 6GB Driver version 2.1 Build_223
I'm not gonna updated my graphic card again. like forever!

#5 25-02-2018 
I tried installing previous versions of my NVIDIA GTX 1060 drivers and that also didn't solve the problem. Immediately after loading a lot, I have a pink flashing soup.

Strange thing is, when I try to run the Sims2EP9.exe file as an administrator, I get a directX 9.0 error and the game doesn't load. When I run it without the administrator rights, the game loads. Does anyone have any idea why would that be? It seems running the game as an administrator is now the only thing I couldn't try to solve the problem because of this error.

#6 25-02-2018 
  • Registered
  • 0
  • 6
Could you try installing the Graphics Driver version "" as exact version as mine? See if this help.

#7 25-02-2018 
@katashkin hello!

I have found the driver of your version, but the installation gave an error and said "This NVIDIA graphics driver is not compatible with this version of Windows. The graphics driver could not find compatible graphics hardware."
I am on Windows 10, are you as well?

#8 26-02-2018 
  • Registered
  • 0
  • 6
Yes I'm on Windows 10 64 bit
I got this version by uninstall graphic driver from device manager (right click -> uninstall) and then restart the computer then the window install the graphic driver for me automatically and then I look in device manager it said now I got version.
So try uninstall driver & restart computer and let the window install it auto for u?

#9 26-02-2018 
@katashkin did that version of the driver solve your problem? Do you not experience crashes and pink flashes with that one? Uninstalling the driver from the device manager scares me a bit; since quite some people experience difficulties getting their graphics card recognized back again. But if you think that would be THE solution then I might dare to do it Smile

#10 26-02-2018 
  • Registered
  • 0
  • 6
Yes after I have that version all my problems are gone. All pink flash/ dx 9.0c error. It's all gone immediately. So I'm sure this is the only way to solve these problems.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option