Can't get Sims 2 UC to start - Win10, Intel, Nvidia 1060
#1 21-03-2018 
  • Registered
  • 0
  • 2
Hi guys,

I hope someone here is able to help me. I'm having issues getting Sims 2 UC to work on my new gaming laptop with either the integrated Intel or dedicated graphics card Nvidia GTX 1060. I've read through x threads here and on other websites and tried different things for a week now. I'll try to explain and what I have tried so far below.

Full screen:
Game does not start. I get the "Failed to find any DirectX 9 compatible graphics adapters in this system!" error message with both Intel and Nvidia card.

Windowed mode (adding -w in target field):
- Intel card - Sims 2 starts but is stuck in low resolution (320x300). (See attachment lowresIntel.gif)
- Nvidia - White screen, sims 2 cursor and sound (See winmode_nvidia.gif).

What I've tried:
- Always start as administrator
- Replaced the Sims2EP9.exe file with the noCD version
- Tried graphic rule maker
- Added intel and nividia cards in Video cards.sgr file manually - tried both "NVIDIA GeForce GTX 1060" and "GeForce GTX 1060"
- Added 1920x1080 in the graphics rule file
- Installed DirectX 9
- Clean installation (with DDU) of nvidia drivers (new and oldest I could go - 385.28)
- Start in and in no compatibility modes
- Deleted/renamed the sims 2 folder in documents/ea games several times

Thank you in advance!

Attached File(s) Thumbnail(s)

.txt  EMLEE-config-log.txt (Size: 9.55 KB / Downloads: 416)
.txt  Graphics Rules.sgr.txt (Size: 34.16 KB / Downloads: 412)
.txt  Video Cards.sgr.txt (Size: 27.95 KB / Downloads: 474)
.txt  DxDiag.txt (Size: 98.48 KB / Downloads: 416)

#2 22-03-2018 
Hi there. I noticed you attached these two files as ending in .txt:

.txt Graphics Rules.sgr.txt (Size: 34.16 KB / Downloads: 1)
.txt Video Cards.sgr.txt (Size: 27.95 KB / Downloads: 1)

Do they look that way on your computer also? Because they're NOT supposed to. They should look like this:

Graphics Rules.sgr
Video Cards.sgr

(No .txt at the end.)

I don't think the game can read them otherwise.

#3 23-03-2018 
  • Registered
  • 0
  • 2
No but I couldn't attach the files in sgr format here so had to change them to .txt. They are in .sgr on my computer Smile
Edit: Wanted to add, thanks for the reply!

#4 23-03-2018 
Ok. I have the game running on a similar (but a few years older) MSI gaming laptop with a dual chipset, so it can be done. (Hopefully.)

A couple of follow up questions:

1) How are you installing the game, and have you tried a reinstall? (If UC, might also be worth trying Origin's repair process, but you will need to replace your .exe and config files afterwards.)

2) Run this 4GB patch on your no-CD game executable: (I'm pretty sure this is non-negotiable now with your version of Windows and your NVIDIA GPU. From what I can tell, this makes far more of a difference than any compatibility mode.)

3) If you wouldn't mind, force the game to run on your NVIDIA GPU (through the NVIDIA control panel), and post another config log? (In the one you posted, it's trying to use the Intel.)

4) After these steps, try again, via the NVIDIA GPU, in fullscreen mode (I seem to recall my MSI doesn't like windowed mode).

#5 24-03-2018 
For the heck of it, I tried getting my dual-chipset MSI Ghost gaming laptop (GTX860m/Intel HD 5000) to run the game in windowed mode, and it's not having any. It just displays a white window. Tried a few things (I think it used to work in windowed mode on this machine, before the windows 10 shenanigans? not sure). So if nothing else, I guess try sticking to fullscreen for immediate troubleshooting, if you decide to try the steps I mentioned.

#6 05-05-2018 
  • Registered
  • 0
  • 1
I hope it's not an issue I'm piggiebacking this thread, I've got a very similar setup and I've also tried all the same possible fixes

I get the directx 9c error when trying to run in fullscreen, I can run windowed but the max resolution is 800x600, which is unplayably small.

Attached File(s)
.txt  DESKTOP-0DTQB59-config-log.txt (Size: 10.3 KB / Downloads: 356)


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option