Ingame pictures partly black
#1 03-05-2018 
  • Registered
  • 0
  • 3
Hey there,
I already found some very helpfull advise in this forum, when I tried to run the UC on my old laptop - ultimately it worked perfect.
With the new laptop (also Windows 10) however, I'm facing some different problems.
When running the game on the stronger nvidia graphics card, there are some weird glitches in graphics: First off there are some black or grey transparent squares in different size that appear on the screen - when moving around, they stay on the same place. If i change & save the 'smooth edges' setting they disappear for some time. Honestly, this one wouldn't bother me very much, I just mention it for the sake of completeness.
The other glitch is much more annoying: when taking pictures with the ingame camera, all of them are partly black. I attached pictures of both bugs, maybe someone has an idea on it ...
I searched the web, but could find anyone with the same problem.

In addition the game crashes on a very regular basis, but this seems to be happening a lot with the newer graphic cards ...
Since Sims 2 is my absolute favorite game of all times, I would be really, really happy about a solution Wink


Attached File(s) Thumbnail(s)

.txt  DESKTOP-EEC29VR-config-log.txt (Size: 10.25 KB / Downloads: 373)

#2 12-05-2018 
Did you use Graphics rules Maker to recognize your video card? The sims 2 is an old game, and has difficulties in dealing with modern systems.

Use this link to download and follow the tutorial:

Do not use compatibility modes to run the sims 2, this has no effect on Ultimate Collection.

To finish, remove the CACHE from the game, tutorial at the link below:

I hope it helped you.
Tell me what happened after these procedures.

#3 16-05-2018 
  • Registered
  • 0
  • 3
Thank you very much, Augusto, for your message!

I use the graphic rules maker for my game and i clean the cache everytime I play.
I already spent a lot of time with Windows 10 and the Sims 2 (+ Nvidia), read through lots of forums and managed to run it pretty perfect on my old laptop. However, now with the new one, the game shows this weird overlay-bug when I run it on the fast Nvidia-card. It runs acceptable on the slow Intel-card but lags a bit and I would love to play with high graphics Wink
I searched around the web and nobody seems to have this same bug ... well, maybe there is somebody around here or maybe someone has an idea Smile

#4 17-05-2018 
I would use the Nvidia overlay instead of the in game camera, and see if that works better. Or you can try Fraps, or do windowed mode and do print screen.

#5 21-05-2018 
  • Registered
  • 1
  • 2
I had the same problem with the pictures once. Try changing the resolution and then changing it back, that usually solved the problem for me.

#6 21-05-2018 
  • Registered
  • 0
  • 4
Try to run it in windowed mode? just add -w in the target of the Sims 2 shortcut. Maybe it helps, I never had such a thing yet I do have a GTX 1060 graphics card.

#7 22-05-2018 
  • Registered
  • 0
  • 3
Thank you all so much for your ideas!

A different camera is definitly worth a try ... although I love to go through every households photo album when playing them after some time.

Changing the resolution back and forth works for me too - but only with the weird grey squares, the pictures stay blackened, no matter what setting I use (have tried everyone I could find Wink).

I will try to run it in windowed mode, who knows ...


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option