Unable to run Sim 2 Ultimate (ACCESS_VIOLATION)
#1 13-07-2018 
  • Registered
  • 0
  • 1

I've registered and decided to post here to ask for some help as I've exhausted every possible option I can think of in getting Sims 2 to run successfully on my PC.

- Intel i7-4790k
- Nvidia GTX 1070
- 32GB RAM
- ASUS Z-97 Pro Gamer
- Windows 10 (latest update)

All of my attempts are with a clean installation of UC, I've never installed or played Sims 2 on this machine (or at all though origin) before, there's no custom content or any additions, purely a vanilla Sims 2 UC.

So far I have tried the following, in various different combinations over the last week or so (* indicates my current install is with these steps):
- Adding my graphics card to the Video Cards file (in both Config and CSConfig) *
- Using the Graphics Rules file provided here. *
- Modifying the texture memory to 8088 (and tying various different combinations). *
- Enabling the driver memory manager. *
- Disabling software rasterising.
- Running the 4gb patch on the vanilla exe.
- Using the noCd exe
- Running the 4gb patch on the noCd exe
- Setting the CPU count to 1
- Running in windowed mode.
- Every compatibility mode option possible (from 95 up to windows 8)
- 8bit colour mode
- 16bit colour mode
- Disabling DEP for the Sims 2 exe *
- Giving all users unlimited permissions to the sims 2 documents folder. *

Without some of these steps the game crashes during initial loading (with the 4gb patch on the vanilla exe it doesnt even run at all).
Currently I can get to the main menu, opening any existing location crashes during the loading screen, as does trying any tutorial. Creating a new custom location does work and loads the blank area, however clicking anything else then causes the game to crash.
With the NoCd exe and 4gb patch I can get to the same thing, but with horrible pink flickering everywhere.
I've been clearing out the Sims 2 folder in my documents before each launch, just ot make sure as well.

Attached is my DxDiag, config log, the Video Cards and Graphics Rules files (with extensions changed to txt so the site would let me attach them) and the exception logs a) from the usual error and b) from when it errors after I create a new custom place and click a button.

I'm pretty sure I tried a few other things to resolve this too, but I can't remember all of them unfortunately.

Any help would be greatly appreciated Smile

Edit: May or may not matter, but my monitor is running at 144hz, I know this causes some issues with other games, but I wouldn't know what to do in this instance.
I also noticed I only ever have the accessories.cache file, none of the others are ever present for me to delete (groups.cache for example)

Attached File(s)
.txt  Sims2Exception 2018.07.13 18.01.17.txt (Size: 13.44 KB / Downloads: 330)
.txt  Sims2Exception 2018.07.13 17.18.40.txt (Size: 500 bytes / Downloads: 348)
.txt  DESKTOP-M5V38G7-config-log.txt (Size: 14.85 KB / Downloads: 317)
.txt  Graphics Rules.txt (Size: 34.42 KB / Downloads: 367)
.txt  Video Cards.txt (Size: 26.71 KB / Downloads: 328)
.txt  DxDiag.txt (Size: 103.12 KB / Downloads: 359)
(This post was last modified: 13-07-2018 06:46 PM by Kezyma.)


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option