"resetting" a comm lot
#1 21-10-2018 
Okay, so this is the situation.

A comm lot has been owned by a sim (any sim) who eventually sold the lot back to the community. And then the stupid stuff starts.
Normally, when a sim visits a comm lot, the lot loads just the same as any other. When the progress bar is full, it may take a second or two, three before the actual lot and the sims appear on screen.
But when a lot has been owned and was sold back, at least in my game, things are different. When the progress bar is full, the loading screen stays up (sometimes for up to a minute and a half) while I can hear doors opening and closing, and sims walking around and doing stuff. And when the lot and sims then finally appear on screen, for every second that I had to wait, a sim minute has passed. So if I had to wait 90 seconds, for my sim an hour and a half has passed. Lost time in which they have done nothing, but their motives were all negatively affected. And in those 90 sim minutes, there was nothing that *I* could do with the loading screen still being up.

I do not want to start over with a clean original copy of the community lot as if it has never been owned. I want the lot to stay as it is, INCLUDING whatever changes were made to object settings while it was owned. But I *do* want the weird waiting time to be eliminated. So, my question is:

Is there a way to accomplish that? And if so, WHAT is that way?

#2 21-10-2018 
I have no idea how to accomplish it off the top of my head.

1. Are you able to put the game on pause while it's loading? And does it still load when that happens?
2. Have you tried minimising/maximising the game - I believe that sometimes that fixes the loading screens.

Alternatively - have you thought about selling the lot back to a holding sim - will that change things with the loading?

to be honest, I've never tried doing the business stuff so all of this is conjecture.

#3 21-10-2018 
Hi @celebkiriedhel,

1. I have... but trying to pause a game while the loading screen is on... it's very hard to verify that it even works. Not while it's still loading, of course, because that will not work for certain. But when loading is done, and I hear sims moving around. As far as I can hear, pausing has no effect. The only thing I know, is that my own sim has yet to arrive when the loading screen finally goes away. But that is true, whether I try to pause the game or not.

2. Minimizing/maximizing also does nothing except force-pausing the game.

3. Having a holding sim own the place *does* fix it. But what if there is no reason for any of my playables to own that place? If there is nothing for them to gain from it?
That would mean that I'm required to make a holder sim especially for owning this place... Yet another stupid dummy NPC-like sim that my sims will undoubtedly meet and want to get to know... And this holder sim will be required to actually hire sims for the positions that normally get manned automatically on unowned lots. And those idiots would need to be trained, if I want them to be any good...

It was originally only owned for a short moment to set up some custom objects, the settings of which cannot be altered while the place is unowned. Like Pescado's "Authorized Personnel Only" mod. I had better not do such things again on comm lots, if this is invariably the result.

In addition, I've even tried moving the lot to the lots and houses bin, and then placing it back in the hood from there. That also had no effect.

So far, it has all been pointless. I thank you for trying, Kiri. Very much appreciated.

I'll just keep looking, and hoping that someone out there has an angle that I didn't think of yet...

#4 22-10-2018 
Great. 1 and 2 are useful to know. Yeah, 3 is sort of a last resort.

I think the next thing that I would try is to compare the package innards of the lot with a lot that's never been owned to see what is different. It may be that you can tweak something in Simpe for it. The thought in my head is that maybe it's stalling because it doesn't buy back the lot properly so there's an endless loop going on where it's looking for it to be bought, and its' not and it doesn't error instead, it just loops.

I use a holding sim for things like orphanages, banks, etc where I want to control what's happening with the some things in a little more detail. You can use the prisoner token to stop the holding sim from leaving their lot (Inge's prison system). So you can avoid your playable sims meeting them. I can't guarantee that you won't want to play them, though. Smile

#5 22-10-2018 
Have you tried moving the lot to the bin and back?

#6 22-10-2018 
@celebkiriedhel I was thinking in that direction as well, but there's a lot of data in a lot file. Wading through all that in SimPE... This page by joandsarah77 may come in handy, I think. And this tool by Cyjon as well.


@leefish Thank you for helping. From my previous message:

Quote:In addition, I've even tried moving the lot to the lots and houses bin, and then placing it back in the hood from there. That also had no effect.

However, later, after I restarted the game, I visited the lot once a few hours ago, and it seemed to act normal. But I was tired, so I may have dozed off for a moment, and missed the pause. Shortly after, I went to bed.

I'm careful not to immediately shout that it's fixed -- I'll need to play some other sims visiting it -- but I'm hopeful.
And even if it's fixed, I'm not immediately saying that moving it to the bin WAS the solution -- I'd need more examples like that to make that determination -- but it may look that way.

So I think it's time for me to make another backup of the hood, and try me this one more time, and again, and again, to see if I can make this consistent.


On a slightly related note: one of my searches led me to this link. If that list of Symptoms of Neighborhood Corruption is the final and complete list (it is not, apparently), then I'm happy to report that none of my 'hoods are facing any problems. I'm experiencing none of these symptoms.

#7 22-10-2018 
I'm crossing all appendages for you BO. Jo's list looks like a good thing too - I'm bookmarking that.


Sorry, that is a members only option