Sims 2 from Origin - Crashing on Create-A-Family, Windows 10
#1 04-12-2018 
  • Registered
  • 0
  • 1
Hi everyone,

I figured I'd ask here since this seems like a really friendly community in helping getting these kinds of issues solved. I recently downloaded Sims 2 from Origin, and I've been having some problems with it crashing on the Create-A-Family screen. The minute I click on the button to generate a new Sim, I'm faced with an Access Violation error message (Code 0xC0000005). There's been a couple of times where it actually got through to rendering the Sim, but those have been anomalies, so I'm fairly confident it's a memory issue.

I've tried quite a few different things such as the 4gb patch, switching a couple values with regedit, but after no luck with that, I just went ahead, repaired my files via Origin, and I'm starting from scratch. I've attached 3 files from a fresh run after the repair: 1) My config log, 2) The most recent exception log, and 3) a dxdiag report.

Hopefully you guys have seen enough of these Windows 10 issues now in 2018 that it's not too much of a hassle to tip me off in the right direction. Regardless, any help or insight you guys can give me on the issue is deeply appreciated. Thank you so much!

Attached File(s)
.txt  DESKTOP-V7RAEIH-config-log.txt (Size: 10.26 KB / Downloads: 301)
.txt  Sims2Exception 2018.12.03 17.25.05.txt (Size: 13.53 KB / Downloads: 326)
.txt  DxDiag.txt (Size: 69.45 KB / Downloads: 390)


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option