Barely There Glass Door is actually Quite There On One Side
#1 30-12-2018 
For some reason one side of the Barely there Glass Door (the taller glass door from Ofb, without the vents at the top) is only transparent on one side. The other side shows the wall. I have attached an image to help illustrate this.


Any ideas on this one? I feel like it is sort of recent, but honestly I can not say for sure when it started. I've attached the log and I'm on Windows 10.

Attached File(s)
.txt  OLIVERII-config-log.txt (Size: 14.9 KB / Downloads: 385)

#2 30-12-2018 
I have occasionally had that with other glassy doors as well. Most notably, this happens when there is an object next to that section of wall on one side, or when something is hanging from it, like a painting or a mirror, for example. Normally, such objects prevent you from placing the door, because the passage would be obstructed. However, if moveobjects is turned on, you can place the door anyway. And sometimes, the game then shows the wall instead of the glass.

I've justed checked, and in my game, either the door shows normally on both sides, or - when the moveobjects cheat was needed to place it - it would show the wall on both sides. So I cannot get the half-there effect that you get.

I cannot imagine how something in the config-log could be responsible for this, unless it happens with ALL glass doors, not just with the Berely There. But because I have been known to be wrong sometimes, I will look it over. That's the least I can do, right?

#3 30-12-2018 
I am aware that moveobjects does funny things with cutouts with both doors and windows. Move objects is not used in this case. I have also recently repaired my game files on the pretense that something happened to them for some reason.


Interestingly the one door can be stacked on itself if they face different ways. I tried other doors and I believe this is unique to this door.

Edit: Just to be clear I can put this door on itself as long as I rotate it (Say, a E-W can be placed on a W-E). Also, I can not mix this with any other door (as far as I know-- I did try some!) in any orientation.

#4 30-12-2018 
Ah, you responded while I was editing my previous post... I had not expected such a quick reaction.
That's a very interesting effect you get there... I've never seen that before. Mixing two doors... you do that WITHOUT the moveobjects cheat? I can't do THAT, either!

Config-log file tells me nothing... or maybe I don't know what to look for.

#5 30-12-2018 
Haha, sorry about that.

I also can't image the config log will help, unless my graphics are doing something strange with some setting that EA used only on this one door for some reason.

I have no idea why this one door seems so buggy. I know for a fact I should NOT be able to put it on itself.

I did have the brainwave that perhaps the CEP could be responsible. It does seem like the CEP includes some kind of a fix related to these doors. If that file became corrupt in a game crash I was thinking it could be possible it's causing issues. However I reinstalled the CEP and no dice. Next action is to start a new userdata file and see what happens. Maybe I have some CC that is somehow causing this on only this door?

I will update the thread with my progress to help anyone else with this or a similar issue. If you have any ideas I don't mind hearing them!

Well, I return with good news. A new, empty user data / my documents folder does not have the issue meaning I have some CC that is causing this.

Now I just have to figure out what that is...

#6 30-12-2018 
And you did it again... But never mind, it's all good Smile

I can tell you that CEP does not do this, because I have CEP and no issue.

The only thing that I can think of, is that there is a custom object in your game that interferes with that door.
The only way to be sure, would be to rename your "Downloads" to something else, or to move it to a different location, and then delete the groups.cache and restart the game.
Then see if you can get the same results. Let us know what you find.

And now I see you've edited your post too. So you've confirmed my suspicion that a custom object must be responsible. I think it *must* be a door. So I would start checking all custom doors, if I were you.

#7 30-12-2018 
Well, I was thinking maybe the CEP had somehow become corrupt.

At any rate I moved my downloads folder to the desktop and the problem persists. I even disabled custom content with the in-game setting on top of that and still had the issue. There must be something in a folder somewhere that the game is still seeing and loading. Can you think of anything?

#8 30-12-2018 
Hmm, in your previous post, you said that the problem was gone without CC. Remember?

(30-12-2018 03:45 AM)DamonDamore Wrote:  Well, I return with good news. A new, empty user data / my documents folder does not have the issue meaning I have some CC that is causing this.

Now I just have to figure out what that is...

Okay, so maybe it isn't in your Downloads folder, but in another subfolder in your "My Documents/.../.../The Sims 2 <whatever>" folder. Try every sub-folder in turn, until you find the right one. And when you do, see what's in that folder. And if there's more folders in it, try removing each one of those in turn... keep making the group of suspect files smaller until only one remains.

Yeah, I know this is a horrible lot of work. But eventually, it MUST help you figure out which file is the culprit.

#9 30-12-2018 
I think I was working on this too late last night. It 100% is in my Downloads folder. I even tested the downloads folder on the new folder to double check.

I have used the method where you remove half your content, check if the issue stops-- if so, you know it's in that half. If not, it must be in the other half.

One thing I noticed is that the doors wouldn't update until I went into live mode for a little bit before moving it. But maybe that has to do with how cutouts work. I do a little sims 2 modding but I am not really up on the cutouts.

I tracked it down to the stairwalls on MTS available here

However, it is not a problem with the walls themselves. Downloading and installing a fresh copy does not cause the same issue. I can only assume the package files some how became corrupt in just the right way to cause a problem with this one door.

Also, thank you for your help!

#10 30-12-2018 
Ah, so you've now fixed it, and you've done it mostly by yourself, too. Well done!
Alas, it had nothing at all to do with graphics cards! So now I must scold you for using the wrong section for this thread...

Hahahahaha, just kidding!


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option