Sims2 x DirectX9 x WIN10 x can't run
#1 24-02-2019 
  • Registered
  • 0
  • 2
Hello! I'm from Taiwan, so English is not so good><
Recently I bought a new notebook "ASUS vivobook S15 X510UF"
I installed TS2, EP8 The apartment life, but can not run the game!
when I clicked the exe. It always shows the same " Failed to find any DirectX9 compatible graphics adapters in this system! Please make sure you have a DirectX9 compatible graphics adapter and have installed the latest manufacturer provided driver..."

I searched so many website but can not find any solution...
I really want to play TS2 ><!!!!!

1. Down there is the txt file.
2. The system of my computer is WIN10 home 64 bit.
3. I tried run the game in window mode but didn't work, hope someone can help me plz and thx!!!

.txt  JESSIEASUS-config-log.txt (Size: 1.01 KB / Downloads: 319)

.txt  DxDiag.txt (Size: 96.92 KB / Downloads: 361)
(This post was last modified: 24-02-2019 04:19 PM by ovaltine24.)

#2 24-02-2019 
Your config-log file shows VERY little information. Clearly even the loading screen didn't come up. But fortunately, your DxDiag report does give us a little more information.

DirectX 12 is much too advanced for this game. DirectX 9.0c would've been preferable, but that often doesn't seem to work under Windows 10.
So I would suggest you try to install DirectX 11. The game should run fine with that.

#3 25-02-2019 
If you are using a nocd hack make sure the hacked exe is in the same place as the original. Do not try and run the nocd from desktop or any other folder.

#4 25-02-2019 
  • Registered
  • 0
  • 2

Yes!! I tried to put the hacked exe. into the same folder and successed!!
But now..I stocked on the family loading screen...
I wait like an hour but still remain the same screen..
I'm not sure what happened exactly qq.
I saw many situations like installed too many mod, but I only installed the EP, SP and the patches needed for update EP (for the install use)
or the problem is those patch?
Ps. Thanks for you two's reply. ><

#5 25-02-2019 
It might be the nocd, or it might be a dodgy torrent. Post your new configlog and we will look at it.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option