AMD Radeon, quad core, graphics rules woes
#1 29-03-2019 
  • Registered
  • 0
  • 5
I have provided my config-log.txt, and also my graphics rules + video cards files zipped, both normally installed in Program Files (x86) -> Origin Games -> The Sims 2 Ultimate Collection -> Fun with Pets -> SP9 -> TSData -> Res -> Config and CSConfig folders.
.zip (Size: 15.24 KB / Downloads: 372)

I am running Windows 10 (64bit), on an HP Envy 15m-bq021dx. CPU: AMD FX-9800P (bristol ridge) GPU: AMD Radeon R7 (bristol ridge)

My game runs pretty well- but it's not where I'd like or expect it to be. I still have jagged edges with smooth edges maxed, unless I'm zoomed in very close to my Sims/lot. Textures are blurry. Lag is present, but it's not unbearable. I have a considerable amount of CC, so that's to be expected. I feel like something in my Graphics Rules/Video Cards is off that I'm just not seeing. I've been fighting with this for months- reading every thread on this forum, using Graphics Rules Maker (eventually went the manual route), messing with different drivers, but I'm at my wits end, so here I am! I was hoping I could get some advice from the experts Blush

My laptop has a quad core processor, and shared system/video memory. I've learned online that my CPU has 8 compute cores 'with the impressive graphics shaders count of 512'. 512 doesn't sound impressive to me, but is that for each core? I'm not sure how to use this to my advantage with this game- maybe I simply cannot.

Notice how my graphics card doesn't have a specific model name? Because it doesn't. It's literally just AMD Radeon™ R7 Graphics, as it appears on my device manager. I'm not sure if this is where my issue is arising, but I suspect it could be, because the Video Cards log that generates in my game folder in My Documents -> Config when I run the game is completely different than the one I have installed in my program files. I have my card at the top under ATI as AMD Radeon ™ R7 Graphics. When that video cards log generates in My Documents, it's at the bottom of the ATI section, without the ™, just as AMD Radeon R7 Graphics. Bah!

things I've tried:
  • adding CPUCount to my target, 1 2 and 3, no considerable difference
  • used Radeon texture fix from leefish
  • applied the 4GB patch
  • scheduled emptystandbylist task
  • removed SecuROM and ran trashreg
  • tried graphics drivers from the HP website and AMD, seem to run exactly same, currently using AMD suggested drivers
  • removed TM from registry
  • have used various compatibility modes
  • windowed mode. does run a bit better!

I'd love for someone to take a peek at this! I adore this forum so much, it has been so incredibly helpful to me. Thank you again!

#2 29-03-2019 
  • Registered
  • 0
  • 5
Here is a DxDiag as well, just for fun.
.txt  DxDiag.txt (Size: 96.33 KB / Downloads: 323)

#3 30-03-2019 
Hi @madison207,

I'm going to take a look at those files for you -- as I'm sure others will --, but it would've been easier if you'd just attached them WITHOUT first zipping them up.
This section is set up to accept .log, .txt and .sgr files without any problems Smile No worries, though... We are Borg; we will adapt. Smile

According to the config-log.txt file, the system DOES recognize the graphics card: it's not reported as "Not in Database", so the "Video Cards.sgr" file would HAVE to be correct. As a result, we would not have needed that file.

In my opinion, the system works best if it ACCURATELY knows your screen resolution.
According (again) to your config-lof.txt, you're at 1920x1080.
In the Graphics Rules file, however, I have found one thing that I think you should change. Near the end of the file, in the section "option ScreenModeResolution", the last block, for the high setting reads:
setting $High
      uintProp maxResWidth      1600
      uintProp maxResHeight     1200
      uintProp defaultResWidth  1024
      uintProp defaultResHeight 768

I would change the numbers for maxResWidth and maxResHeight, if I were you. It might help.

Also, again according to the config-log.txt, your texture memory is reported to be 1744MB, which is the default Celebkiriedhel value. And what do you know? When I look at your Graphics rules, there it is, on lines 47 and 48:
# Kiri - manually setting texture memory
seti textureMemory 1744

Fortunately, your DxDiag gives more accurate data. I think you should change line 48 to read "seti textureMemory 4319" (without the quotes, of course).

And, after editing the Graphics Rules file, copy it to the other Congfig Folder as well, of course. Smile

#4 30-03-2019 
  • Registered
  • 0
  • 5
WOW, BO!! 4319, huh? I'm excited to try that out. However...
I tried to apply the 4319 update and the resolution options. I did a quick google search, and it looks like my actual resolution is 1536 x 864. I applied these changes in my config files and graphics rules, but that resolution option doesn't show up for me in game. I hopped to My Documents to see if my logs were changing back again... and they are. In My Documents, despite updating the files in Program Files AND My Documents before running the game, my texture is defaulted back to 512 and my resolution changes are gone. However, the changes I made have been saved and not changed in SP9 Config and CSConfig in Program Files. What's going on here!? I've attached the files how I saved them, and how the My Documents files appear after running the game (NOT zipped this time Blush) thanks again!!!
.txt  Graphics Rulesoriginal.txt (Size: 33.44 KB / Downloads: 310)
.txt  Graphics Rulesafter.txt (Size: 33.43 KB / Downloads: 315)
I'm going to try going into every single game folder and replacing the graphics rules files to see if that helps me. Maybe it's pulling it from somewhere else.

#5 30-03-2019 
  • Registered
  • 0
  • 5
An update. I replaced every file I could find, set the one in My Documents to Read Only, cleared my cache files for good measure and the texture fix finally stuck!!! My game looks really really nice, and its running even faster which was a pleasant surprise. However, the resolution still isn't working for me, but that's just a minor annoyance. I'm probably not going to play on windowed mode anymore.

#6 31-03-2019 
Yeah, I'm not surprised that the game interfered and changed the Graphics Rules on you... Normally, the game NEVER does that, but if you feed it RIDICULOUS information, what do you expect?

I advised you to change the MaxResWidth and MaxResHeight values of ONLY the "Setting High" section of the Graphics Rules.sgr, but then you changed it for ALL sections, and then you copied these settings to DefaultResWidth and DefaultResHeight, too!!! You cannot blatantly copy the Max values to the Defaults and then think that the game knows what to do with that! The game cannot deal with that! It sees nonsense, so it assumes that some idiot has corrupted the files! And the only way for the program to fix that, is to restore the absolute defaults that were built into the game.

Also, you didn't use the values that I found in your Config-log.txt (1920 x 1080, the values that the game itself suggests).

And finally, the game normally only READS the Video Cards.sgr and Graphics Rules.sgr files. It does not write to them, unless you mess stuff up. And the game does not READ the config-log.txt file. It only WRITES to it, to tell us what hardware and what settings it found, and what errors it encountered. WE read that file to find out how we can get the game to work again.

Anyway, my point is that you should ONLY edit the Graphics Rules.sgr file, and ONLY make the changes that I suggested. And after that put the file back where you originally took it from, according to your first post, being the Program Files (x86) -> Origin Games -> The Sims 2 Ultimate Collection -> Fun with Pets -> SP9 -> TSData -> Res -> Config and CSConfig folders". And that is ALL that you should do.

YOU asked for help. I gave you help. Why don't you at least TRY to do exactly as I said? THEN, if that doesn't work, you can make other changes if you like. If this is something that you cannot do, if you just start experimenting on your own, WITHOUT first trying to do what I told you, then please do not be surprised if I do not help again.

#7 31-03-2019 
  • Registered
  • 0
  • 5
Yikes, wow. I'll figure the rest out. You can close the topic. Thanks
(This post was last modified: 31-03-2019 05:39 PM by madison207.)


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option