Win10 + newer card (gtx 1060 6 gb) - what works for me
#1 10-08-2019 
  • Registered
  • 0
  • 2
Hello, first post here Smile

So I just created an acount to share my experience with running ts2 on a newer machine, and i won't say that it works flawlessly, but i can run the game for 2-3 hours at a time without crashes or pink flashing. I do not use a lot of custom content though, around 2gb I think. I will try to explain the best I can what I did, in the hope that it might be useful to others.

First a disclaimer of some kind, I guess. English is not my first language, so if something I wrote is not clear, feel free to ask for clarifications, I'll do my best. I do not work in any tech/computer related field, so I'm not a "pro". I probably can't explain why something works, all I can say is what worked/works for me. This post is not intended as a complete and exhaustive tutorial to make your game work. That being said I am willing to try and help if I can. Finally, I am very sorry I you try what I did and it doesn't work for you, I know what it is to try to play the game and running into so much issues you just have to give up.

Okay, buckling up, this is going to be a long post.

My specs :
Windows 10, version 1803, build 17134.885 (auto updates are on), French install if that matters
MSI laptop with intel core i7-8750H, nvidia gtx 1060 6gb, driver version 430.39 (not up to date, i'm freaking out :roflSmile
(I also had problems on my (much) older laptop though, wich was more of a middle range with win8 and later 10 and an nvidia GT 740M)

game install:
I have the game on disks, but the last reinstall i did on my older laptop was a nightmare, so i downloaded the collection from that abandonware site that got posted on tumblr. So it's not the UC, but a repack that was probably made from the original disks (the game installationi files look like my old install, no like the one the UC has with all the bundles).
My installation folder is located on my D:\ drive, so not my system C:\ drive. This is important, because with 10, programs installed in the default folder get some kind of "mirror" of the whole installation in a hidden folder (called roaming or app data). If you installed in the default folder and you can't get your card recognised by the game, it might be because you have to replace the GraphicRules and VideoCards sgr files in those folders as well. I have no experience of that though, i just read about it while trying to fix my game and thought it was worth mentionning.
Be aware though, that if you use another folder than the default for installing files, it is recommended to write protect that folder (just like the default folder is).

fixes that worked for me

1) windowed mode.
It might seem a stupid thing to say, but my MSI will only run the game windowed. On my older laptop, it would only run in full screen. The game will try to run full screen by default, so the first time I tried to run it, I got an error message and the game didn't launch. I think it was the "arrg err invalid" something error, but don't quote me on that Blush. Workaround is to add -w to your program shortcut.

2) resolution:
The main thing that won't work as intended is the resolution. I tried everything I found about this issue, I just won't get any other resolution in the game other than 400x600 or something like that - very very small. I use a combo of the shortcut command above (-w -r1024x768) and that handy little program called bordeless gaming. It makes the game run as if it was full screen. The -r1024x768 part depends on your specific screen resolution of course, that's what i use but you may want to use different values.
At first though, the shortcut command trick didn't work. In the game's shortcut properties, there is a compatibility tab, and there in settings, you have a button called something like "change display scaling settings" (for me it says "modifier les parametres PPP eleves"). I just unchecked everything in there, and the shortcut command started working.

3) Fixing the graphics
The first time I loaded a test neighborhood, everything was flashing pink. Important here, don't forget to use a test hood while testing!
There is that very cool tool, the graphic rules maker. Unfortunately, I am apparently an idiot, and it doesn't work for me. The first time i had to fix the game, it did not exist, so I used kiri's files. Which is a very good time to say: thank you so so much kiri, you literally saved this game for me and undoubtedly for a whole lot of people, and numerous times at that. So, yes. I don't know why, but th GRM never worked for me, not with my old laptop, not with the new, so i just go the "old ways" route, and use kiri's files. They are stickied to this forum, and you have to choose the one that corresponds to your hardware. Don't get me wrong though, I would definitely use the GRM if I could, and the people behind the program are no less awesome for what they do.

3.1) The VideoCard.sgr
I added my card to the file, and for those who have the same card as mine, here is the line that I added, I have the 6gb, mobile version:

card 0x1c20 "NVIDIA GeForce GTX 1060"

If you have dual cards like I do, you need to choose which card you want to run the game on. Adding both of your cards will confuse the game (that's been said already, but to my experience, that's very true, and you do not want to add another variable in an already very complicated equation). That's why you need to back up the originals. You can run the game on your dedicated card, and bs on your integrated, since they're basically two different programs if needed.
By the way:
CSconfig folder = bodyshop
config folder = game

3.2) The GraphicRules.sgr
So, as I said, I have to use one of kiri's files. I'm almost confident that I have the nvidia + texture fix one (duh). I'm a fearless idiot though, so I did try severarl of them, mainly on my older laptop since I had that game vs bs not wanting to run on the same card.
Now for the texture memory fix part, I went and entered the value that corresponds to my card's value, which is 6gb, or 6144MB. If you installed one of kiri's file with the fix, there is a line that says
# Kiri - manually setting texture memory
seti textureMemory 8040 <-- that value here is what needs to match your card's vram

Credit for this tip goes to BoilingOil actually, in one of the posts in this forum. That's why at first I had set the value to 8040, but it might be better to match your card exactly.

There are other steps that you can take to help your game run smoother, I have the 4gb fix for example.

Other tool I use: nvidia inspector. It is a third party tool though, so you'll have to decide for yourself if you want to use it or not. It is available from softonic and github, which seem to be safe, but is also redistributed on other sites that rely on ads to generate revenue, so be careful if you decide to try it out. If you have trouble forcing the game to use your nvidia card, this program will force it to do so. In the profile inspector, select one of the sims profile or make a new one, it needs to point to your latest ep exe. In the profile settings, in the "other" section there is a line that says "enable application for optimus", select the second line in the drop down menu, shim_rendering_mode_enabled, apply changes, you're done.

One last thing, I have that graphic glitch when I go to change appearance of a sim in game or load the game CAS. There are like grey boxes overlayed on top of the image... Here is a picture (not mine):

I did not find a fix unfortunuately, but if you go to the game graphics settings, and disable smooth edges completely, the boxes will disappear. You can then set the smooth edges back to max settings. At least that works for me.

And i think that's it. I may have forgotten something, and I apologise because this is probably not very clear, but i hope it at least adds a tiny bit of something useful to the evergoing discussion Smile Thanks and congratulations (?) if you read through all of this, and feel free to ask away/add anything if you'd like !


#2 22-08-2019 
  • Registered
  • 4
  • 9
Hello Zamzam!

I was reading around trying to find some new solution that I did not try yet to make my game work, and I read your post.
It seems that we have very similar machines and situations (that made me smile Smile ), so I'd like to share my experience with you (and ask if we do have the same problems!)

Here my specs:
MSI intel ® Core ™ I5-8300H 2.30 GHz 2.30 GHz
windows 10 home
Intel® UHD Graphics 630 with 4 gb (internal)
NVIDIA GeForce GTX 1050 Ti with 8 gb ram (dedicated)

My game (CD-DVD version) is saved on the : D directory too and the graphic rules maker does not work for me too (about this I suspect the problem is that we do have the game in a different directory than the default one, beacuse when I had the game installed in the : C directory the GRM worked)
I too modified my graphicrules.sgr and videocard.sgr following the kiri indications (and I will not end thanking her for this!)

The main difference between us is that I cannot find a way to play my game: when I enter in the neighborhood (it is the old-saved backed-up game from my old pc), the pink flashing appears immediatly and everything I do ends with crashing.

What I did no try:
1)I didn't try to use the windowed mode (I could not imagine that it would make a big difference!): so I will try it (after discover how to set it) and I will tell you.
2) 4 gb patch correctly applied: I tried in every known way to fix the 4 gb patch, but memory only grew at 2 gb (by default it was at 1 gb!). Tried every tip found on the web (move it on the desktop, in the CSBin, etc...) and the only thing I did not tried was to use different .exe (some users says that the solution might be to use more flexible .exe), but I do not know where to find it.
I know here on leefish is posted one for Mansion&Garden, but I do have Apartment Life as last expansion. Where did you manage to download yours?

I hope to find out a solution with this two tips...they are my last hope!!

#3 29-08-2019 
  • Registered
  • 0
  • 2
Hi eegee91!

I'm sorry I couldn't answer earlier. I will try to help you but first, did you try to make a post about your problems here ? Other, more knolwledgeable people than me might be able to help you better Wink

Of all the things I've read about the type of card we have and win10, is that you have to be very lucky to get your game to work (though I'm not usually very lucky with things like this, so I still can't believe it does work for me).

About what you said, can you check if your game does indeed run on your nvidia card ? You can look it up in your config log. Mine says
=== Graphics device info ===
Name (driver): NVIDIA GeForce GTX 1060
Name (database): NVIDIA GeForce GTX 1060
Kiri: Hardware rendering is enabled

and also:
Texture memory: 6052MB

As far as I understand, pink flashing means the game doesn't know how to properly use your graphics memory. Does your card have 8gb dedicated memory ? If so then I think the texture memory line in your config log should say 8040MB (it has to be changed in the GrpahicsRules first).

I don't think windowed mode will change anything, it's just that for me, the game just won't run in full screen. actually that might meen that we don't have that similar of a setup, but I'm just guessing. If you'd like to try it, it's easy, here is how mine is done: I have a shortcut on my desktop to the game exe (which is Sims2EP9, since I have everything. I don't use the launcher, it is just one more useless step to run the game. Saying this just to make sure you have the same thing). Right-click that shortcut, and choose properties. In the window that opens, you should see a line taht says "target" (or a translation of that if your system is not in english), with a box next to it, that has the path to the game's exe in it. In that box, add a space after the text that's already there, and then -w. Save the changes in the lower right, and you're done.
The game seems to only want to run either in full screen or windowed mode with later cards though, so if the game refuses to launch after making those changes, you can just revert back by deleting the " -w".

i think it is weird that the 4gb patch just gives you 2gb, and the game has only 1gb by default, since it was supposed to have 2gb by default ? I think I saw tips on how to make sure your game has the patch applied, let me look for a link and I'll post it here. Also, did you try to run the game without the patch ? I don't think the pink flashing has anything to do with how much ram the games uses, instead, it depends on how the game handles the graphics card memory. Meaning : it should work even without it, it would just crash earlier (the game always end up crashing after some time, anyway, the patch just makes it so you can run it longer). Since you main problem is the pink flashing, I think this is what should be taken care of first.

You said you try to load an older save, and that when entering the neighborhood, it flashes pink. Do you have any cc in ? It might be better at first to test everything without cc, and to make a new neighborhood for testing, or just use a maxis one. If you load a default nh without any cc, is the pink flashing still there ?

About the no cd patch for AL, I'm afraid I don't know, since I've been using MG as my latest ep for years... I'm not sure about a safe place where to get one either, since there seems to mostly be problems (malware, etc) with sites that host them. By the way, did you manage to install the game on win10 without issues ? Last time I tried, it was such a nightmare I just gave up and got that collection i talked about earlier. I also have the UC on Origin but... no thanks if I can avoid it Big Grin)

This is all i can think of for now, I really hope you or we Smile can find a way to get your game working, best of luck!


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option