TS2 Disc version, Win8 not starting with DirectX message
#1 07-09-2019 
  • Registered
  • 4
  • 7
My game is refusing to start... first time I click the icon it gives me a warning about not being able to find Direct X. Second time it opens the game, but sits on the title screen and doesn't load.

It was working the other day and I haven't touched the download folder or anything else since. Clearing the cache files doesn't work either.

I run Windows 8, I have all EPs and SPs installed from original discs, with a no CD crack so I can start it without the disc. Config logs are attached.

Any Ideas?

Attached File(s)
.txt  DANIELLE-config-log.txt (Size: 10.31 KB / Downloads: 331)

#2 07-09-2019 
Hi @decat,

To avoid confusion, I've removed the other config-log.txt, because it was over a year old and therefor totally irrelevant.
I remember you! Last time we spoke, in Februari 2018, you were running under Win10. Good of you to downgrade to Win8. I imagine that gives a lot less problems. Sad to see that you have a problem again.

Unfortunately, at this moment, I see nothing weird in your config-log.txt. So I would like you to try the following:
1. Shut your computer down, and then start it up again.
2. Go to your TS2 Logs folder, and delete ALL the files there.
3. Try to start the game.

If the game still doesn't run, try to run the DxDiag program and attach the resulting output file, please.

#3 07-09-2019 
Re-install DX9. I had a HP gaming machine that did this, with Win 8.1Pro. Just keep a copy of the DX9 install in a folder where you know where it is, and re-install it when it does that. I found going from an external monitor, to the laptop display is one of the things that triggered this.

Let us know.

Make sure you back up your entire, EA Games folder in "Documents", to either a high capacity flash drive, or an external hard drive, so you don't have to start completely from scratch, if you need to re-install the game.

#4 08-09-2019 
  • Registered
  • 4
  • 7
Hi, thanks for the help, I re-installed Direct X 9 and it seems to be working! thank you!

#5 08-09-2019 
You're welcome. Keep it handy. BTW... Welcome to the pond!Smile


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option