very fustrated, direct x 9.0c error
#1 08-03-2020 
  • Registered
  • 0
  • 4
hi im having trouble getting my game to work. i have windows 10 and the game just does not want to work. and im starting to feel like giving up.
i'm not a tech whiz so i found the instructions hard to follow even if they are so simple. its rather frustrating on my end because i just want to play the sims 2 on my laptop that is just over 2 years old
i tried everything possible but i didn't want to mess up my computer Huh

edit: i also have the ultimate collection

posted on a new thread as suggested.
thank you in advanced for any help given

Attached File(s)
.txt  DESKTOP-00G8SHP-config-log.txt (Size: 9.55 KB / Downloads: 340)
.txt  DxDiag.txt (Size: 97.97 KB / Downloads: 448)
(This post was last modified: 09-03-2020 03:27 AM by Sheerio895.)

#2 09-03-2020 
Hi @Sheerio895,

In some ways it's a pity that your machine is only 2 years old. Because an even older machine would probably work better, especially if you had Win 7 or Win 8.x installed on it, instead of Win 10. Because the combination of Win 10 on a modern machine is exactly why The Sims 2 will not properly run anymore.

Here's the problem: DirectX 9.0c is what you need for your game, but DX9.0c cannot be installed on Win 10 computers. And DX 12 does not properly emulate the DirectX function s that DX9 would. The solution would be to install DX 11, but that's impossible as long as DX 12 is installed. And more and more applications that work on Win 10, require that DX 12 is present. On an older system with Win 7/8.x, there would be no problems, because you would simply install DX9.0c.

However, let's just see what we can find that does NOT involve the age of your system and Windows version.
First of all, your game doesn't recognize the video card, because that isn't included in the Video Cards.sgr.

To fix that, you would need to open the Video Cards.sgr file from your "Mansion and Garden Stuff/TSData/Res/Config" (disk version), or from the "Fun with Pets/SP9/TSData/Res/Config" (UC) installation folder, depending on which version of TS2 you have. Then you would have to find the section that starts with the following line:
vendor "Intel" 0x8086

And under that, you would have to add a new line reading

card 0x591b "Intel(R) HD Graphics 630"

After that, you'd have to save the file, and make a copy of it in the CSConfig folder.
But I realize that if you think the instructions that you've tried to follow so far, were complicated to do, this rather simple thing *may* also be somewhat beyond your abilites. And this was only the first step, which -- on its own -- is not yet likely to make the game work.

You have more than sufficient memory, according to your DXDiag, but your game sees only 1GB, which means that you will need to run the 4GB patch. I don't know where to find one of those, but that may actually be a good thing, because you will also need a No-CD executable to play your game. And I know one that works to solve both problems at once! Here's George. You would need to download the file under the link, and unpack that in the folder where your "TS2EP9.exe" file is currently installed. And yes, I am aware that this sounds like another very complicated instruction. And it gets worse if your Windows doesn't know what to do with a .rar file, because then you need to download and install another archiver first. I would suggest a program like WinZip or IZArc.

And even if you can follow all the above, this still doesn't mean that your program will run yet. We may need to fix more, but I cannot see into the future what the problems might be.

So, I hope that this helps you a bit. If not, please let us know, and we will see if someone I or someone else can help you overcome your obstacles.

#3 09-03-2020 
  • Registered
  • 0
  • 4
oops should've been more specific i have the Ultimate Collection that i got through origin

#4 09-03-2020 
  • Registered
  • 0
  • 4
welp after god knows how long of trying to get the game to work i FINALLY got the game working. I don't know if it was what you suggested or adding the -w in the target after right clicking > properties I CAN FINALLY PLAY THE SIMS 2
adding the -w worked straight away
(This post was last modified: 09-03-2020 04:10 PM by Sheerio895.)


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option