direct x 9.0c error on TS2- HELP!
#1 10-03-2020 
  • Registered
  • 0
  • 2
So I recently upgraded to Windows 10 from Windows 7 and I've been having the problem it seems A LOT of people have with TS2 on Windows 10- though from what I've read it seems that at least up until now, I've been a bit more fortunate than some. The game was running just fine for me- and in fact looked MUCH better than it had before (likely owing to the fact that I had JUST re-installed- for the first time in almost SEVEN YEARS, I kid you not!- it due to a major computer crash that happened just before we decided to upgrade to Windows 10. I also lost a good portion of my CC in said crash, so I'm sure that helped, too.). It also seemed to RUN much faster and smoother than before- until I went into CAF to create a sim couple to serve as the genesis of my new neighborhood. After several minutes- you guessed it- the game froze (not crashed, oddly, just froze).

This continued to happen, so I did some digging around and quickly determined that first and foremost, I was going to need the 4g patch. So I downloaded it and installed it. DIdn't work. Game still froze- and also started actually crashing from time to time. Also tried downloading the graphics and video card fixes and those didn't work (I think I may have inadvertently downloaded the wrong ones, though). Then I Tweaked the in-game settings to ease some of the burden on my computer and tried running in windowed mode, just in case full screen was proving a bit too much for good ol' Windows 10 to handle (plus that way I could easily force quit the program if a freeze occurred). No go (except that it actually STARTED perfectly fine in Windowed mode instead of just getting stuck on a white or black screen, which from my research seems to happen to a lot of people) So I did MORE digging around and realized that I was also going to need a no-cd executable. So I downloaded one- that I found here, with the 4G patch preinstalled. And now I can't even get into the loading screen. I just get that direct x error message, which I have naturally attached a screenshot of below, along with my config-log (though I doubt that's going to help you much as it's naturally from when I last tried to started the game and couldn't) and a dxdiag.

Any help you could offer would be VERY much appreciated. Oh, and just to warn you, I'm not the most computer literate gal on the planet so I'm going to need someone to explain it to me like I'm five. Thanks in advance!

Attached File(s) Thumbnail(s)

.txt  RADFAM-PC-config-log.txt (Size: 1.09 KB / Downloads: 291)
.txt  DxDiag.txt (Size: 71.16 KB / Downloads: 353)

#2 10-03-2020 
Hi @FemGamerPlayer,

You're already in windowed mode, so we don't have to try THAT as a possible solution anymore.
You've already found "George" (the 4GB no-CD patch), apparently, so we don't need to look there, either.
As you already guessed, the config-log is of no help at all. And the dxdiag... well, without the config-log, that doesn't help us, either, except to confirm that you have BARELY enough memory and are running the dreaded DirectX 12.

Why do I say "BARELY enough memory"? Because according to the DXdiag report, your machine has a total of only 4GB. 1GB of that will no doubt go to windows, leaving you with 3GB to work with. And that 3GB will have to be shared by the game data and the onboard graphics card. The only thing that has kept you floating so far, was the virtual memory -- the pagefile.

I can imagine that with these apparent hardware specs, the 4GB patch makes things too difficult for your system to handle. It tries to reserve 4GB for the game, on a system that doesn't have 4GB to give! So I hope that the DXdiag report is false, and that you have more memory in your system. Otherwise we can try as much as we want, but the game is not going to work very well for you.

And then there is the DX9 error that you get. I would almost suggest that you uninstall DX 12 (which doesn't do DX 9 functions very well), and install DX 11 instead. But that *might* cause trouble if other applications require DX 12.

Beyond that there is nothing much I can say at this moment that would help. So I can only hope that this is enough, or that someone else has more hopeful news for you.

Good luck.

#3 11-03-2020 
  • Registered
  • 0
  • 2
(quote removed by BoilingOil; the quoted message is right above this one, so quoting was a little unnecessary)

I'm willing to try anything at this point (and the stuff I use now is the same stuff I used back when I was running Windows 7, which doesn't have DirectX 12, so I'm not worried about other stuff not working!). But how do I uninstall directx 12? Everything I've seen says you can't. But maybe I'm just missing something?

By the way, rest assured the DxDiag must have been acting goofy about the memory- My hard drive is 118 gb, with 67.6 free. And I have played the game when it had FAR less than that available without any major issues (although granted, that was back when I was running Windows 7). So I'm not all that worried about that aspect at this point. Smile
(This post was last modified: 11-03-2020 11:54 AM by FemGamerPlayer.)

#4 11-03-2020 
Ah, about uninstalling DX12... Apparently, that is not necessary after all. You just need to tell your system to use a previous DirectX version, because they would all be present in the installation. The articles that I saw, claim that this is possible, but I could not figure out how, because I do not run Win 10, and thus don't have DX12. I have Win7 and DX9.0c.


I can understand that you're willing to try anything. Now let us just hope that one of the things you *can* try, will also be good enough to help you play TS2 again Smile

Now about the 4GB thing and DXdiag: Everything that you install, is stored on the hard drive, because the files will stay on the hard drive even when it is turned off. But programs cannot RUN directly from the harddrive, because that is too slow. That's why one also has RAM memory, which is much faster than the hard drive, but also more expensive. There are also more technical reasons why a computer has less memory than it has hard drive space, but that is not important right now.
When you turn your computer on, the files that are important for Windows to run, are copied FROM the hard drive into memory. And when you select a game or another progrma to run, that must ALSO be copied into memory. You cannot run all the programs that are on your hard drive, all at the same time, because you do not have that much memory.
My computer has about 1.500 GB of hard drive space, but I have only 16 GB of memory. Most modern computers nowadays have at least 4 GB memory, but 8 GB or 16 GB is much more common. And some have even 32 GB. Your hard drive is 118 GB, but your memory is something else. and it seems that DXdiag thinks it's only 4 GB. Now DXdiag *could* be mistaken, but the 118 GB is most certainly NOT your memory.

Maybe you could try this: Right-click your taskbar and select “Task Manager” or press Ctrl+Shift+Esc to open it. Click the “Performance” tab and select “Memory” in the left pane. That will tell you how much memory your system has. (I've looked this up on Google as well, because I have no Win 10 on my system).

I hope this all helps you.
Good luck.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option