Windows 10 - Crashes in Build Mode Consistently ((Not a CC Error))
#1 11-04-2020 
I'm hoping someone can help me as I'm at my wits end.

I've done the 4gb patch, I have the Nvidia Graphics Fix from LeeFish, I've done a completely clean reinstall, and still the issue persists:

I can install a certain combination of cc, and then after that anything else I add to the game causes crashes as soon as I go into Build Mode. I've done 50/50s for the last 4 months. I either can't have anything or I can only have a handful of folders (10 for example) in any random combination. As soon as I add anything else at all - foods, bedding, vehicles: instant crash in build mode. It's bizarre as I've never had this type of problem with this pc before.

I've tried uninstalling updates, and that didn't work to resolve this either. I've been getting frustrated because with each 50/50 on the same content, I find a different set of 'problem files'. These are always files I've had in game before with no problems whatsoever because I always download the same set of cc. I have around 40 folders in, and it all works perfectly... until I add the folder containing cars. Crash. The car folder works perfectly, until I add bedding. Sometimes it's a folder that only contains some wall and floors, other times it's a folder that has a single poster mesh in it. It's random things each time, and each time my config log tells me 'Access Violation' and there's no way to find out what's causing the problem.

I suspect it's not my cc, as again, I've done 50/50s for months - loading testing, one file at a time, or half the folder at a time - doesn't matter. Always a different set of conflicts, always a different set of issues.

Please, any help would be so appreciated! I am preparing to try DEP as the last thing I did was to do a complete clean reinstall of Windows 10 AND TS2 and that did absolutely nothing.

Attached File(s)
.txt  DESKTOP-QNERPLB-config-log.txt (Size: 10.33 KB / Downloads: 447)
(This post was last modified: 17-04-2020 04:34 AM by Teru8.)

#2 11-04-2020 
I have enabled DEP but am afraid to reload for fear it will crash again. Where I can I download Windows 7 if this fails? I just don't know what else to do. Please help. I would so appreciate it.

Attached File(s)
.txt  DESKTOP-QNERPLB-config-log.txt (Size: 10.38 KB / Downloads: 354)
.txt  Sims2Exception 2020.04.16 22.52.46.txt (Size: 13.25 KB / Downloads: 366)
(This post was last modified: 17-04-2020 04:35 AM by Teru8.)

#3 17-04-2020 
Is anyone here? The DEP has not worked. I do not know what to do. Please, if anyone has suggestions for something I haven't tried yet, or anything at all it would be much appreciated!

#4 17-04-2020 
Hi "Teru8",

I think that - like me - everybody else read your thread, but none of us had any idea what to tell you. Everyone decided to think it over, and then forgot to get back to you. That's not how it's supposed to go, and I sincerely apologise for everyone here.

I must admit, though, that I'm still at a loss for solutions. I have absolutely no idea what could make the game react the way you describe it. Sorry.

#5 17-04-2020 
wave I've lived with this problem since 2008, or so... I can't have more than 3.48 GB of CC in my game (Win 7) - no matter what I do. And, it doesn't matter which 'set' of CC it is. Prior to 2008, on my original Sims 2 PC (which was an XP) I had over 25 GB of CC. I spent years (literally!) weeding, culling, renaming, repricing, cleaning that CC - and got it down to about 10GB of stuff that I really needed. But, every machine since then (there have been 3-4, going through W7, 8, and now 10) can not go over the 3-4GB limit. Yes, I have tried all the fixes. Been there done that. *sigh* So, now I have only my excruciatingly necessary Build CC in the game (at 3.48GB) and I build. Sorry to be the bearer of sad news, but there you have it. Please let me know if you find another solution Cool

#6 17-04-2020 
Hi @CatherineTCJD:

Oy, I was going to mention size of the Downloads folder, but then scrapped that, because 10 folders, as Teru8 describes it, could never have added up to the approximately 25 GB I've heard people claim to have added to their games. I myself have never had much more than 2 GB of CC in my game - originally because of the load times -, and I never moved on from Win7 - which I'm still using -, so I never hit any limits, and thus had no idea that the changes between Windows versions were THAT bad.

Thank you for opening my eyes.

#7 17-04-2020 
@BoilingOil and @CatherineTCJD

Thank you for your replies! I appreciate it - I asked on another forum as well and got a good suggestion that I wanted to double back and share in case anyone else might be dealing with this problem:

Apparently my graphics card is 2gb. I had no idea to be honest, and feel rather silly. I'm planning to upgrade to a 4gb graphics card and see if that makes a difference - and I do want to point out that I'm quite hopeful it will as I play with almost the same set of cc in the bootcamp partition on my Macbook and it runs smoothly with no problems at all (which I find hilarious given that it's not even a proper Windows 10 installation but alas. Computers always defeat even my best attempts to wrangle them.)

I will order the new card and do the upgrade, and then I'll share my results here to see if it helps others. I honestly love that about TS2 - there's many many of us who have done and tried nearly everything, so there's such a wealth of community knowledge.

Thank you for your time both of you!

#8 17-04-2020 
Please let us (well, me Wink anyway!) know if anything works for you.

My current card is Nvidia GeForce GTX 650 - which, according to the manufacturer, says it has:
Memory Specs:
Memory Clock 5.0 Gbps
Standard Memory Config 1024 MB
Memory Interface GDDR5
Memory Interface Width 128-bit GDDR5
Memory Bandwidth (GB/sec) 80.0

My system information also tells me it has a total available graphics memory of 4096 MB
... which means it's more than 2gb? Right?
(I'd repost my log, but the W7 machine is offline - so that's a PITA to do right now - but it was all looked-over/checked by BO and HL a few months ago.)

#9 18-04-2020 

I PM'ed you.

#10 31-07-2020 
Hello my fishy friends!

I wanted to come back and update as I've found out couple of things.

First, I upgraded my pc's ram from 4GB > to 8 GB> to 32 GB and I found that each upgrade increased my object limit just a little bit. I still went back and cleared out my folders, but I am able to load everything I want at the moment!

Unusually though, I've been dealing with sudden and persistent pink flashing which has never been a problem before. My thought is that increasing the amount of ram has resulted in Windows 10 going 'aha! There's RAM - lEts uSE iT fOr rANdoM nONsEnsE." I'm not giving up. @CatherineTCJD, try upgrading your RAM - it's got a lot to do with your cc bandwidth, and I'd also encourage a clean out while you're at it, as I found that I didn't actually even use around 40% of what I'd downloaded. I only snagged it because I *thought* I *might* use it. I learned my lesson when I realised I must have had thousands of files with object data - not the hundreds I had thought I had.

Urgh. Where would we be without TS2 refusing to work, crashing, or otherwise acting a fool eh? For now I've created an empty standby list as a memory allocation fix since I've tied the issue pretty firmly to my upgrade from 8gb to 32.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option