Installing the 4GB patch breaks my game?
#1 10-10-2020 
  • Registered
  • 2
  • 3
This is probably going to be something stupid I've overlooked, but please bear with me.

I recently got a new laptop after my last one died and decided I was tired of Sims 4's bullshit. I installed Sims 2 Origin Ultimate Edition on a Windows 10 (64-bit) operating system. i5 quad core with 8GB RAM and intel integrated graphics. Game launches as-is. Zero mods are installed save for my replacing neighborhoods with clean versions. I updated the video cards and graphic rules files to support 1080p (see attached). System now recognizes my card, even if the texture memory seems a bit high. I haven't delved much into the game itself yet because I prefer to get the pre-install housekeeping out of the way before I start adding too much CC, but the game is loading in 1-2 minutes and defaulted to high settings.

What I cannot get to work, however, is the 4GB patch. Whenever I attempt to use it, the game stutters and refuses to launch. If I resolve this either by putting in a new copy or undoing the changes, the game loads fine again. In fact, when I used CFF Explorer to edit it back, the game instantly started working.

Things I have tried so far:
  • using the NTcore patch on Sims2EP9.exe (the last executable) while in the TSBin folder
  • using the NTcore patch on a version of Sims2EP9.exe I C&Ped to my backup folder (NOT a shortcut) then C&Ped back into the TSBin folder
  • both of the above but using CFF Explorer to check the "app can handle >2gb RAM" option, both ways
  • cleared my cache many, many times
  • also tried clicking off the "32 bit word machine" app as that was suggested in at least one thread I saw while googling potential solutions
  • tried each of these while in compatibility mode for XP SP2, then with compatibility mode
  • raised my fist and shook it menacingly at my ceiling
  • tried patching before I updated the sgr files AND again after
  • tried shutting off read-only access for the folder, and for the desktop folder where I was working
  • yelled several profanities in Simlish
  • deleted my cache files yet again

So what am I missing? I don't remember having this much trouble on my last PC. I attached the config log and my sgr files for good measure. The log does not show any crashing as the game never actually starts but I imagine it's still instructive.

Any advice or suggestions would be highly appreciated. Thank you so much in advance.

Attached File(s)
.txt  MSI-config-log.txt (Size: 10.34 KB / Downloads: 310)
.txt  Video Cards.sgr.txt (Size: 26.72 KB / Downloads: 311)
.txt  Graphics Rules.sgr.txt (Size: 34.16 KB / Downloads: 299)
(This post was last modified: 10-10-2020 01:53 AM by strangelylit.)

#2 10-10-2020 
After running the CFF/4gb stuff - don't tick the 'run as admin' box. that will undo the 4gb setting.
And, do you have "George" - that will help.
Sorry I can't help more Confused Good luck!

#3 10-10-2020 
  • Registered
  • 2
  • 3
(10-10-2020 04:56 AM)CatherineTCJD Wrote:  After running the CFF/4gb stuff - don't tick the 'run as admin' box. that will undo the 4gb setting.
And, do you have "George" - that will help.
Sorry I can't help more Confused Good luck!

Oh, my google-fu didn't find THAT post. Thank you! Only problem is, George appears to be AWOL. I don't suppose you or someone else out there has a George I can love and squeeze?

#4 10-10-2020 
Here Lies George. Don't know if it's kiri's version or my own backup of mine.

#5 10-10-2020 
  • Registered
  • 2
  • 3
George (and turning off 'run as administrator') fixed it! Thanks, everyone!


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option