Direct 9.0x Error/Tried Everything on Thread-HELP
#1 25-11-2020 
Hi all,

I have a new Dell Gaming Laptop G5 SE with Ryzen 7 and Radeon discrete graphics, so it uses dual cards including the Radeon RX 5600M.

I followed the previous thread and have added both cards to the Video Cards.sgr in config and csconfig and adjusted the Graphic Rules to what everyone suggested.

Even with adding my Video Cards, I still get the Directx 9.0x error. PLEASE PLEASE help, I miss my sims 2 game!! Please see my log below, along with the .dxdiag and the Video Cards.sgr to show that I put everything correctly.

Thank you all for your help!

Attached File(s) Thumbnail(s)

.txt  JACQUELINE-config-log.txt (Size: 10.33 KB / Downloads: 308)

#2 25-11-2020 
Do you know how to do a Dxdiag.txt?

How to do a dxdiag.txt

The graphic rules and video cards files need to be set up. Once you've done the dxdiag and posted it on here, I will do this for you.

Also if you can let me know what Operating System you have, and whether you are using Ultimate Collection, or the CD/DVDs.

If you've set it up, you've not put it in the right place.

#3 25-11-2020 
Thank you, thank you, thank you. I had a feeling I might have been building it incorrectly.

I am on Windows 10, I am using the Ultimate Collection. Please see attached dxdiag.txt.

Attached File(s)
.txt  DxDiag.txt (Size: 104.2 KB / Downloads: 382)

#4 26-11-2020 
In the Program folders:

\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\Config\
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\CsConfig\


I've attached the files. you need to install them in the above folders.

Test it out, and then come back and let me know - if there is still a problem, you will need to add your latest -config.txt

Attached File(s)
.rar  metastargate.rar (Size: 6.68 KB / Downloads: 320)

#5 27-11-2020 
Thank you @celebkiriedhel for all of your help!!

I uploaded both files you gave me in the path you gave me for config and csconfig, but I still got the direct 9.0x error. Below is the config log, please let me know if there's anything else you need.

Attached File(s)
.txt  JACQUELINE-config-log.txt (Size: 10.33 KB / Downloads: 269)
(This post was last modified: 28-11-2020 12:51 AM by metastargate.)

#6 28-11-2020 
Whoops, thought I posted config log @celebkiriedhel

Attached File(s)
.txt  JACQUELINE-config-log.txt (Size: 10.33 KB / Downloads: 284)

#7 28-11-2020 
It's not picking up the changes...

So this is a thing - I will quote what HugeLunatic and ChrisHatch have said about it -

Chris Hatch: "As HugeLunatic said Windows User Account Control (UAC) has protected your Mansion & Garden Graphics Rules and placed it into the 'virtual store' and using that one instead of the one in M&G, the path to that is %USERPROFILE%\AppData\Local\VirtualStore (you can copy and paste that straight into Windows Explorer's address bar) and from there the folder hierarchy is the same as C:/ drive. "

It's probably because it's using the copy in the Virtual Store. So deleting it from there will enable the graphic rules in the correct place.

You can tell if the right graphic rules is being used - the graphics memory is not 32mb.

#8 28-11-2020 
OK, so I typed in this path: "%USERPROFILE%\AppData\Local\VirtualStore" in windows explorer and it says "this folder is empty" - there are no files in there.

I also deleted the .bak files that I had in Config and checked CSConfig, but it didnt have any. I checked to see if maybe the virtual store was under the "public" user and no such luck. But I figure because the log file says "Jacqueline" that it has to be under my user.

I attached the screenshot showing the Virtual Store is empty and my current log after deleting the .bak files. Not sure what else to do at this point and THANK YOU @celebkiriedhel - check your yahoo email if you haven't already Smile.

Attached File(s) Thumbnail(s)

.txt  JACQUELINE-config-log.txt (Size: 10.33 KB / Downloads: 278)

#9 28-11-2020 
@celebkiriedhel OK, just wanted to give an update that I did a repair of the game and then re-loaded the video and graphic files you built for me. I then added those files to EVERY single expansion pack that had a config and csconfig file in case it was reading it somewhere else, but like you said in the previous thread, it's doubtful this will fix the issue.

I am NOT using graphics rules manager in case you are wondering.

I'm wondering if I should uninstall the game completely and re-install and try again.

#10 28-11-2020 
@celebkiriedhel OK, so I realized the log that I was giving you, if you read the top, it says generated in October. Which I think is my old computer. There is another config log that was recently generated and lookie here... its trying to read Nvidia? Maybe if we add this Nvidia card, then we are good to go??

See config log (new)

Attached File(s)
.txt  DESKTOP-32M8O66-config-log.txt (Size: 9.54 KB / Downloads: 298)


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option