CAS blue screen pls HELP (sims2UC)
#1 26-11-2020 
  • Registered
  • 4
  • 3
Okay guys (browser reset my window so my entire post got deleted as i was ab to post so this is gonna be fast)

Basically been playing the sims 2 Ultimate collection and its been wonderful reliving my childhood, but I wanted to change from the default res and fix my textures and stuff so i decided to start editing my file and everything even tried the one you guys offer on your site, (didnt fix my issue) but the resolution changes it made were correct and made it where i didnt have to find it lol.

Anyway the game is at 1920x1080 now and everything works, and looks amazing, HOWEVER when starting CAS it loads like normal then when it opens all I can see is a Blue screen apart from the UI in the regular spot at the bottom left corner, where I can do the normal things like Name my sim, add a sim, cat or dog to my family, but i cannot see the sim, or the background at all, not even off to any side (that im aware of, unless its just soooooo far off screen it makes it blue lol. I might also add that during all of this, the game remains functional, like i can edit the options, add people to the family, save game, load houses, make towns, all of it. But nothing at all except the UI pops up in the CAS.

Please help.. ive exhausted every bit of knowledge on the sims and computers that i have and i just cant seem to fix it, even reinstalled and its not working.

PC specs:
OS: Windows 10 64-bit, Home ed, Version 2004, Build 19041
Processor: Intel i7-3770 3.40GHz
RAM: 12gb
GPU: Nvidia GTX 1050 Ti (4gb)

I built this pc in 2011 and it had a AMD HD 7870, since then thats the only thing thats changed

Also have but not plugged in:
Onboard GPU: If i remember correctly its a Intel HD 4000?

PLS any help would be greatly appreciated.

.txt  Graphics Rules.sgr.txt (Size: 33.31 KB / Downloads: 333)

#2 26-11-2020 
Can you upload your -config-log.txt for me from \My Documents\EA\The Sims 2\Logs\

The likelihood if the CAS is not working but everything else is, is that you haven't put the graphic rules.sgr and video cards.sgr in the CSConfig folder.

I'll know better if you can send me the config-log.txt from both your game and your body shop load.
How you do this is
- load the game, save the config-log.txt from logs folder, and rename it game-config.txt.
- load bodyshop, save the config-log.txt from the logs folder, and rename it bodyshop-config.txt

upload them both here, and mention me so I know to come and have a look.

#3 29-11-2020 
  • Registered
  • 4
  • 3
i swear i replied with this last night...

However, I finally went through and tried the uninstalling thing again, and to my surprise i got it right this time! I can now see everything in cas again, now i just need to fix the resolution and textures and ill be a okay.

Never figured out what caused my issue, seems to be like im literally the only one thats ever had it happen, but yeah. thanks anyways Smile

#4 21-05-2023 
  • Registered
  • 0
  • 1
Hellooo, reviving this thread a year and a half later, because I have the same exact problem and have been looking to fix it now, after fighting with it since forever. Just gonna piggyback off of the instructions...

Attached File(s)
.txt  bodyshop-config.txt (Size: 7.71 KB / Downloads: 130)
.txt  game-config.txt (Size: 10.34 KB / Downloads: 126)

#5 24-05-2023 
You need to copy the graphicsrules.sgr and videocards.sgr from the config folder to the csconfig folder.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option