Stuck in 640x480 resolution
#1 08-02-2021 
  • Registered
  • 0
  • 1
Hi guys.
I'm having a problem that I've never encountered before and actually it's quite hard to find any solutions on-line. Anyway, my problem is that I'm stuck in this weird resolution - 640x480. I have a new laptop and I really wanna play The Sims 2 on it. On my old laptop everything worked fine, I managed to fix all the problems and the resolution was 800x600 at first (as it usually is I guess?). I have smooth edges on (they are not greyed out), my graphic card is recognized, I mean everything is fine, BUT the resolution. It's driving me crazy because I think I tried everything. My graphicrules.sgr is GraphicsRules-Nvidia-Max1920 from this site. I've tried many things, graphic rule maker, but it made no difference. Guys, I really need some help, because I'm going crazy as it seems impossible to fix.
Thanks and have a nice day.

System Information
Time of this report: 2/8/2021, 1115
Machine name: LAPTOP-8T2CUC5L
Machine Id: {3FC3C620-CAEB-4227-9AB2-BCB8EEF4BC8A}
Operating System: Windows 10 Home 64-bit (10.0, Build 18363) (18362.19h1_release.190318-1202)
Language: Polish (Regional Setting: Polish)
System Manufacturer: LENOVO
System Model: 82AU
Processor: Intel® Core™ i5-10300H CPU @ 2.50GHz (8 CPUs), ~2.5GHz
Memory: 8192MB RAM
Available OS Memory: 8100MB RAM
Page File: 7776MB used, 2243MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 12

Card name: NVIDIA GeForce GTX 1650
Manufacturer: NVIDIA
Chip type: GeForce GTX 1650
DAC type: Integrated RAMDAC
Device Type: Full Device (POST)
Device Key: Enum\PCI\VEN_10DE&DEV_1F99&SUBSYS_3A4217AA&REV_A1
Device Problem Code: No Problem
Driver Problem Code: Unknown
Display Memory: 8011 MB
Dedicated Memory: 3962 MB
Shared Memory: 4049 MB
Current Mode: 1920 x 1080 (32 bit) (120Hz)
HDR Support: Not Supported
Display Topology: Internal

Attached File(s)
.txt  LAPTOP-8T2CUC5L-config-log.txt (Size: 10.3 KB / Downloads: 300)

#2 25-02-2021 
  • Registered
  • 0
  • 2
Did you solve this? I'm having the same issue with a Lenovo 1650Ti laptop (AMD processor)

I'm starting to think it might be the 120hz screen that can't be set to run at 60hz. Maybe the game doesn't like that?

#3 25-02-2021 
  • Registered
  • 0
  • 2
I fixed it. It was the 120hz refresh rate that caused it. When going into fullscreen, The Sims 2 tried to run at 60hz, but it couldn't. (DirectX-error)
Had to manually add all resolutions at 60hz using CRU (Custom Resolution Utility) from here:
Add with CRU.exe then run restart64.exe

Hope this works for you as well!


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option