Long launch time & graphical artifacts at max edge smoothing
#1 27-04-2021 
  • Registered
  • 2
  • 4

I've been trying to set up the Sims 2 UC (via Origin) on my desktop for a couple hours now, and I feel like I've run out of ideas at this point.

I'm trying to run it on a Ryzen 5 3600 processor paired with a Radeon RX 5600 XT. I'm also on a 144hz panel if that changes anything.

I first tried running the game with the 4GB patch, along with Graphics Rule Maker settings, with my GPU added to the database, but no dice.
Launching only seems to change my desktop resolution and softlocks my computer if I don't kill the non-responding TS2 process quickly enough.
No error message or anything.

I've attached my config log with the "WITHOUTD3D9" prefix for this scenario, in case someone spots anything wrong.

Next, I tried running the game using the d3d9.dll library as a bit of a last ditch effort. I set the memory to 1700MB (which prevented crashing during loading screens), and finally got the game to run.
Doing this, I get some pretty bad graphical artifacting (different colors and checkerboard patterns mostly, pretty much all over the screen).
I've read that turning up edge smoothing can fix this. While it does fix it in the neighborhood view, it only reduces the problem once I'm loaded into a lot. It's still pretty much unplayable.

Once again, config log file attached, this time with the "WITHD3D9" prefix.

I'm hoping that you can help me find a solution here, that I've somehow missed something. I'm particularly curious about the first case I've described, I've read about some people encountering a similar softlock/no error message situation, but haven't been able to find a fix that works for me. I'm mostly finding results about the steps described above, or trying windowed mode which doesn't help.

I'd be thankful for any help, I'm struggling more than with any other Windows 10 machine I've tried in the past.

Edit: Got the game to launch without DXVK, but with brand new graphical issues. See replies.

Edit 2: Closing the thread. Turns out checking "disable texture memory estimate adjustment" in Graphics Rule Maker fixed the launch times and performance crawling to a halt thing. Not exactly sure how related both issues were, but turning edge smoothing all the way up now also seems to eliminate the flickering. Can't wait to discover the game all over again now that it works!

Attached File(s)
.txt  WITHOUTD3D9-config-log.txt (Size: 15.16 KB / Downloads: 276)
.txt  WITHD3D9-config-log.txt (Size: 15.19 KB / Downloads: 279)
(This post was last modified: 01-05-2021 01:49 PM by nightvision.)

#2 27-04-2021 
Do you have CC in your Downloads folder?
Have the thumbnails generated? Maybe the game needs 20 minutes to launch - have you left it alone for a while to see if it launches?
Do you have any other processes running at the same time? Browser, anti-virus, Fraps, etc (Don't!)
I would def. go without the Dvx3d9-whatever-it-is... (it messed up my game, when I tried it.)
Good Luck!

#3 27-04-2021 
  • Registered
  • 2
  • 4
Hey, thanks for the reply.

Turns out you were right, waiting works. I was just freaking out because the game was slowly killing my computer's performance while it loaded I guess. No idea why it takes so long or how I can even attempt to help it, I remember it only taking a couple seconds on the last PC I tried. It's even booting off of an SSD.

The problems keep coming though. Now after waiting 5 minutes for it to load, neighborhood and lot view have rectangular sections of the screen flickering in and out of existence (you can see through parts of the lot, down to the terrain) mostly when I move the camera. Edge smoothing reduces it once again, but doesn't fix it.
Placing an object in buy mode also makes most of the lot invisible until I move the camera again.

No CC at all, thumbnails are present. I was hoping to mod the hell out of the game, but I'm really just struggling with making it run at all on this machine haha.

Found the same issue on a 7 year old youtube video, but the proposed fixes are either dead links or simply don't work for me. Really not sure what to try at this point :l
(This post was last modified: 27-04-2021 08:13 PM by nightvision.)

#4 27-04-2021 
Well - I'm glad waiting got it at least to start....
But, I'm sorry, I have no idea what else for you to try. I'm not familiar with Radeon cards either... Hopefully someone else will chime in soon?

#5 27-04-2021 
  • Registered
  • 2
  • 4
Guess I'm gonna have to put my whole Sims 2 nostalgia trip on hold for the time being. Hopefully someone here has encountered and fixed this issue before.
Thanks for the help anyway. Your advice at least got me one step closer to a playable game Smile

#6 01-05-2021 
  • Registered
  • 2
  • 4
Closing the thread. Disabling texture memory estimate adjustment in Graphics Rule Maker fixed all my issues!

I was just messing around with the settings and stumbled upon that fix. Could've sworn I'd tried it already, but guess I just missed it until now.
I'm off to download all my CC and mods again haha.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option