Sims 2 Not responding after 15 min, -config-log.txt graphic card not right - DVD W10
#1 03-05-2021 
  • Registered
  • 5
  • 7

I am running Sims 2 up to Bon Voyage on a Windows 10 Dell Latitude E7470 Laptop using the DVS installation. The graphic card is a card 0x1926 "Intel® Iris® Graphics 540" and is listed in the Video Cards.sgr file.

However the video card listed in my -config-log.txt file is showing the following:

Name (driver): GeForce 7800 GTX
Name (database): GeForce 7800 GTX
Vendor: NVIDIA

The game loads up in a min or two, and families load fine (though it takes several minutes) -- there is no flashing pink, however, without fail, the game will freeze and enter the "Not Responding" status after about 15-20 minutes of gameplay. If you let it sit for around an hour, it might recover, then freeze again. Usually I just close the game and start over... There seems to be no other issues with the game except for this. I have no idea why the driver specified in my -config-log file is completely different from the card in my laptop.

I used graphics rule maker during set up of the game. But I have tried different downloads of the Graphic Rules.sgr file from various forums that state Intel -- however, no matter what I do, it seems the game is still using the G4Force GTX card and driver. And the lagging/freezing/non-responding persists Sad

I am not sure how to get the right driver/card listed in the config-log file, or even if this is the actual problem... but I figure the game should be using the correct driver at the very least.

I've also tried setting all the graphics settings to the lowest/off and the issue continues.
It'd be nice if the game could run for more than 30 minutes without freezing and becoming "not responding" Sad

config-log is attached

.txt  DESKTOP-PDDG1E5-config-log.txt (Size: 10.56 KB / Downloads: 277)

#2 03-05-2021 
The "GeForce 7800 GTX" is because you are using that Dvx3d9-whatever-it-is... (it messed up my game, when I tried it. I don't recommend it.)
If I were you, I'd take out the dvx-thing and get my game to work without it. Good luck!

#3 03-05-2021 
  • Registered
  • 5
  • 7
Ohhh, wow I didn't even think of that! I remember that thing being in the instructions I followed. (I just went and confirmed the file is d3d9.dll located in [expansion pack]/TSBin for anyone curious).

Update: I removed the file and it indeed reverted the graphics card details to the correct ones in the -config-log.txt file, thank you!!:
=== Graphics device info ===
Number: 0
Name (driver): Intel® Iris® Graphics 540
Name (database): Intel® Iris® Graphics 540
Vendor: Intel
Chipset: Vendor: 8086, Device: 1926, Board: 06dc1028, Chipset: 000a
Driver: igdumdim32.dll, Version:, GUID: D7B78E66-5A66-11CF-7152-B826B1C2D635
Driver version: 8681
Monitor: \\.\DISPLAY1
Monitor aspect: 1.786127, 16:9
Screen mode: 1920x1080x32BPP,60Hz
Texture memory: 768MB
HW T&L: Fixed function:1 Programmable:3.0
Pixel program: 3.0
Texture stages: 8
AppControlledAA: 1

However, I've confirmed I unfortunately still have the same "Not responding" issue after about 15 minutes Sad

My machine specs should be more than enough to handle this game, I would think?


Intel® Core™ i7-6650U CPU @ 2.20GHz

Base speed: 2.20 GHz
Sockets: 1
Cores: 2
Logical processors: 4
Virtualization: Enabled

I have also tried running the game with CPUCount:1 and CPUCount:2 and in windowed mode, but to no avail..

What I am seeing tho, is that the game will start using quite a high amount of CPU, but barely any GPU -- which seems odd, but I'm not a professional computer person... so I don't know if that's normal.

I've attached a screenshot of the resource consumption at a moment when the game went into "Not Responding". It is the bottom one (that shows Not responding):

#4 04-05-2021 
Could you post your new ConfigLog - like you did in the first post? Thanks Smile

#5 04-05-2021 
  • Registered
  • 5
  • 7

Sure, thank you!
File is attached!

.txt  DESKTOP-PDDG1E5-config-log.txt (Size: 10.53 KB / Downloads: 305)

#6 04-05-2021 
Thank you Wink
The only thing that is popping out at me is - Force texture memory: 768 Mb - it seems to me like it should be a higher number (mine says 8203 Mb.)

Until someone else pops in here with better ideas... Have you read through and tried the things suggested in this guide? THE SIMS 2, 2021 Guide
...just stay away from the dvx-thingy (IMHO)

Good luck!

#7 05-05-2021 
  • Registered
  • 5
  • 7
Thank you and I appreciate the help!

Everything I've read before states that Intel number should start low and increment as needed. But obviously if it's not working then bumping that number is definitely something I'll try!

I'll go through that guide and again thank you so much for the help you've offered so far! Smile

#8 07-11-2021 
  • Registered
  • 5
  • 7
So I wanted to post a quick update about this.

I don't know the exact cause, but I can give what I now know the issue is. The problem turned out to be a corrupted neighborhood.

I had been trying to play with a custom neighborhood I built probably -- geez -- like 15 years ago. I had restored it when I reinstalled my discs onto my Windows 10 host, and this is the neighborhood I've been continuing to play with.

The other day I after yet another crash, I was mulling over everything this (and other) forums had taught me, and decided one more time to try removing ALL the custom content from the downloads folder.

When I did that, I loaded the game and had the exact SAME problem. This made me think -- well, it made no difference when I cleaned up my CC and went from nearly 14GB down to 4GB.. so maybe it was some content conflicting? Well, when I removed everything, I confirmed that was not the case.

On a whim -- and something I honestly just didn't think to do until yesterday, I loaded up one of the pre-made neighborhoods I've literally never played with, and could tell it was different right away. Even accounting for loading Pets, Weather, Destinations, etc (because I've literally never played those hoods before), it loaded faster than my custom neighborhood!

Once it loaded, I opened up the Roth family, and lo-and-behold, not only did the family load in under 60 seconds, I could actually use the #3 speed!

So this blew my world.

Now I wanted to know whether was ever an issue with my CC content (remember, I had cleared the folder at this point). So I quit the came, restored my CC in the downloads folder, and reloaded the game --> Roth family. STILL NO ISSUES.

So all in the span of 10 minutes, I knew I:
  • Did not have a hardware issue
  • Did not have a Game Setting issue
  • Did not have a CC issue

I wanted to double-check the CC issue, because the Roth family, of course, did not have any CC. So I created a new family using CC and then moved them into an existing house. STILL NO ISSUES. So I knew then that the issue really must have been that over time, the neighborhood I had built had simply become corrupted.

So the conclusion is that the issues I've been suffering from were not with the game itself, or any cc, but with a old custom neighborhood.

So, for the time being, I'll play in the other neighborhood, or try creating a new one and seeing if it's possible to somehow migrate my old saves to it without corrupting

If anyone has any ideas, though, about migrating a neighborhood to a new one -- let me know! Big Grin

#9 08-11-2021 

Thank you for keeping us all informed on your progress. After all the things that had already been tried, corruption was, of course, the most prominent likely cause of your problem. But then there is corruption, and there is corruption. I've encountered forms of corruption that made a certain specific lot totally unplayable, but that could have been cleaned up by the right tool.

You do speak of CC, but I'm curious... do you also have non-CC downloads... like MODS? If you don't already have it, I think you might want to give my No Sim Loaded a try. If you take anything except the Basic version, there's a small chance that whatever corrupts your lot, might be cleaned up after you've loaded any other lot in the same neighborhood, and played until the notification appears. No guarantees, mind you, but it is possible.

#10 08-11-2021 
  • Registered
  • 5
  • 7

Yes, @BoilingOil, I do have quite a few mods

I don't know the exact root cause of the issues with my custom neighborhood, but I can certainly give your tool a try. Possible adding and removing a mod (or mods) broke that neighborhood -- whereas the others were never played, so perhaps were never influenced by that specific issue back whenever it occurred.

It would be great to be able to play again with the families I've been playing with for so long..

I'll post my update here once I've confirmed whether it helps with the lag/freeze/crash of my custom neighborhood. A small chance is better than nothing

Thank you so much -- I appreciate it!


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option