Sims 2 Not responding after 15 min, -config-log.txt graphic card not right - DVD W10
#1 03-05-2021 
  • Registered
  • 1
  • 4
Hello!

I am running Sims 2 up to Bon Voyage on a Windows 10 Dell Latitude E7470 Laptop using the DVS installation. The graphic card is a card 0x1926 "Intel® Iris® Graphics 540" and is listed in the Video Cards.sgr file.

However the video card listed in my -config-log.txt file is showing the following:

Name (driver): GeForce 7800 GTX
Name (database): GeForce 7800 GTX
Vendor: NVIDIA


The game loads up in a min or two, and families load fine (though it takes several minutes) -- there is no flashing pink, however, without fail, the game will freeze and enter the "Not Responding" status after about 15-20 minutes of gameplay. If you let it sit for around an hour, it might recover, then freeze again. Usually I just close the game and start over... There seems to be no other issues with the game except for this. I have no idea why the driver specified in my -config-log file is completely different from the card in my laptop.

I used graphics rule maker during set up of the game. But I have tried different downloads of the Graphic Rules.sgr file from various forums that state Intel -- however, no matter what I do, it seems the game is still using the G4Force GTX card and driver. And the lagging/freezing/non-responding persists Sad

I am not sure how to get the right driver/card listed in the config-log file, or even if this is the actual problem... but I figure the game should be using the correct driver at the very least.

I've also tried setting all the graphics settings to the lowest/off and the issue continues.
It'd be nice if the game could run for more than 30 minutes without freezing and becoming "not responding" Sad

config-log is attached

.txt  DESKTOP-PDDG1E5-config-log.txt (Size: 10.56 KB / Downloads: 10)

0
#2 03-05-2021 
The "GeForce 7800 GTX" is because you are using that Dvx3d9-whatever-it-is... (it messed up my game, when I tried it. I don't recommend it.)
If I were you, I'd take out the dvx-thing and get my game to work without it. Good luck!

1
#3 03-05-2021 
  • Registered
  • 1
  • 4
Ohhh, wow I didn't even think of that! I remember that thing being in the instructions I followed. (I just went and confirmed the file is d3d9.dll located in [expansion pack]/TSBin for anyone curious).

Update: I removed the file and it indeed reverted the graphics card details to the correct ones in the -config-log.txt file, thank you!!:
=== Graphics device info ===
Number: 0
Name (driver): Intel® Iris® Graphics 540
Name (database): Intel® Iris® Graphics 540
Vendor: Intel
Chipset: Vendor: 8086, Device: 1926, Board: 06dc1028, Chipset: 000a
Driver: igdumdim32.dll, Version: 27.20.100.8681, GUID: D7B78E66-5A66-11CF-7152-B826B1C2D635
Driver version: 8681
Monitor: \\.\DISPLAY1
Monitor aspect: 1.786127, 16:9
Screen mode: 1920x1080x32BPP,60Hz
Texture memory: 768MB
HW T&L: Fixed function:1 Programmable:3.0
Pixel program: 3.0
Texture stages: 8
AppControlledAA: 1

However, I've confirmed I unfortunately still have the same "Not responding" issue after about 15 minutes Sad

My machine specs should be more than enough to handle this game, I would think?

Memory:
16 GB RAM

CPU:
Intel® Core™ i7-6650U CPU @ 2.20GHz

Base speed: 2.20 GHz
Sockets: 1
Cores: 2
Logical processors: 4
Virtualization: Enabled

I have also tried running the game with CPUCount:1 and CPUCount:2 and in windowed mode, but to no avail..

What I am seeing tho, is that the game will start using quite a high amount of CPU, but barely any GPU -- which seems odd, but I'm not a professional computer person... so I don't know if that's normal.

I've attached a screenshot of the resource consumption at a moment when the game went into "Not Responding". It is the bottom one (that shows Not responding):
   

0
#4 04-05-2021 
Could you post your new ConfigLog - like you did in the first post? Thanks Smile

0
#5 04-05-2021 
  • Registered
  • 1
  • 4

Sure, thank you!
File is attached!


.txt  DESKTOP-PDDG1E5-config-log.txt (Size: 10.53 KB / Downloads: 8)

0
#6 04-05-2021 
Thank you Wink
The only thing that is popping out at me is - Force texture memory: 768 Mb - it seems to me like it should be a higher number (mine says 8203 Mb.)

Until someone else pops in here with better ideas... Have you read through and tried the things suggested in this guide? THE SIMS 2, 2021 Guide
...just stay away from the dvx-thingy (IMHO)

Good luck!

1
#7 05-05-2021 
  • Registered
  • 1
  • 4
Thank you and I appreciate the help!

Everything I've read before states that Intel number should start low and increment as needed. But obviously if it's not working then bumping that number is definitely something I'll try!

I'll go through that guide and again thank you so much for the help you've offered so far! Smile

1

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option