Win 10 UC Sims 2 game stuck at 1gb memory after 4gb patch
#1 26-11-2021 
  • Registered
  • 0
  • 1
Hi! i have tried many different things to fix my game, including guides from here, mod the sims, and pleasant sims.
I tried replacing my .exe with George, but i couldn't put it directly in my TSBin folder, and so I had to extract it to my desktop, and then copy paste it into the folder. (im not sure if that messed it up) and after running the game through George directly, i checked my config file again, and it didn't change.
I have included both my config log and my dxdiag, and I tried to add my graphics rules file which I made with the GRM, but im not sure if it added properly. I know my system has more then enough memory to run the sims 2 hopefully without crashing, and pink soup.
Thank you for any help/guidance you can offer me.

Edit: I followed marasims' tutorial, specifically the part which linked to a youtube video by The Jessa Channel, and when I scrolled down to check out her mod the sims post, i saw something which she marked important
"**If the 4GB patch is NOT applying right click on the .exe and turn off any comptability mode options you have on it!!**"
I followed this and took off the compatibility options on george, and reran the 4 gb patch, and loaded my game, and when I checked the config file now, it said it was set to the 4gb.
im not sure what this means as far as not being able to run the game as admin, but id rather have the 4gb then admin mode.

Edit 2: after checking the config file and seeing the 4gb patch finally work, i loaded up an actual neighborhood, and not only was my resolution stuck at 800x600, but all the graphics options were low, and the terrain was flashing pink soup, and no amount of changing the Graphic Rules file either by hand or with the GRM has fixed it.

Edit 3: I followed the guide linked here and it completely fixed my problem, and my game has run better then it ever had before

^^^ Guide ^^^

Attached File(s)
.txt  CLAIRVOYANCE-config-log.txt (Size: 10.4 KB / Downloads: 221)
.txt  DxDiag.txt (Size: 96.14 KB / Downloads: 195)
(This post was last modified: 27-11-2021 12:45 AM by LawlessStar21.)

#2 26-11-2021 
Based off your config-log, your video card is not listed in the videcards.sgr. For GRM to be able to save, you need to run it as admin. Because it doesn't look like GRM saved anything, else it would log it's changes.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option