Crashing in CAS/CAF, Households won't Load...
#1 15-12-2021 
  • Registered
  • 0
  • 3
Hey, so even after following the guides I saw to install, I'm still having crashes. It crashes as soon as I try to add/make a sim in CAS/CAF or the Bodyshop; And If I try to load a premade family it just loads for a really long time before crashing if I alt+tab. No error message in the Sims 2 Game, but I do get an abort issue message from the Bodyshop and then it forces it closed. Other than that, the
Game loads fine, neighborhood view seems great, all the graphics fixes seem to be working/okay, the shoreline and all that looks correct with accordance to the example pictures.

I did originally use PleasantSims installation guide which includes the 4gb Patch and GRM; At one point it directs tothis site, Leefish and I tried those instructions even tho they're almost the same (use GRM, etc.) I have already applied the 4gb patch, have used Graphic Rules Maker (which is showing that it saved the settings in the log), I even downloaded Leefish's EP09.exe fix and applied patch to that and was trying to use that version to play.

The game itself loads up, graphics seem to be working right, no UI issues, neighborhood view works great and no lag or trouble loading things. But then when I go into CAS/CAF or the Bodyshop, it instant crashes Sad ?!?! And then I tried to load the Pleasants and see how it works, but it just stayed loading screen on the family portrait for awhile and when I finally alt+tabbed it crashed.

I'm currently using MrDJ's repack since some of my old CD's don't work that well anymore due to time/wear & tear/scratches, so IDK if that changes anything? I don't have origin unfortunately (lost my account 5-10 years ago due to hacking and never got it back so I just abandoned all my games (more than just sims) that were on it :/ and got no help from origin sigh)...

Windows 10, kind of 'older' computer for 2021, a Dell Precision T1600, Intel® Xeon® CPU E31225 Graphics Card. that's a screenshot of my PC's system about page. I also can see my PC shows I have 12.8 GB of free space so I have the 4-8gb available for playing, yes? (Tbqh, RAM and memory and gb and mb etc. have always been very confusing to me...) I'm really lost because the game looks great when I load it up, and no issues with the UI or any flashing or shadow boxes, etc., up until trying to create a sim/family or go into playing a premade family.

I then tried downloading the Graphic Rules.sgr on this forum and replaced the one GRM had installed with, same with the Video Cards.srg. No improvements Sad

Really confused if I'm missing some steps or what? This was a fresh download today (the game/repack, the GRM, etc) and I haven't added any other mods or anything yet, I was mainly focused on getting the game setup with outcrashing or issue so I haven't bothered tweaking or adding anything else. Just the Ultimate Collection, the 4gb Patch, the Graphics Rules Maker, and those last two .srg files.

Attached File(s)
.txt  DESKTOP-15LO8KT-config-log.txt (Size: 10.61 KB / Downloads: 237)

#2 15-12-2021 
Hi, have you copied the latest version of Video Cards.sgr and Graphics Rules.sgr files from your Config folder to the CSConfig folder? That's the first thing I'd try to fix this issue, since the problems don't happen in the normal game, but only in CAS/CAF and BS, which only use the copies in CSConfig, not the ones in Config.

Also, for a more in-depth understanding of your situation if the above doesn't help, we might need to see a copy of your DxDiag.txt attached.

#3 15-12-2021 
  • Registered
  • 0
  • 3
Yes, I did put both in Config and CSconfig. The first two times I was trying to get it to work and use GRM, I didn't. But then after having the issues the first few times, I put them in CSConfig when I saw it mentioned on another post, redid the GRM, but was still having issues. The first time I did the GRM I had none of those downloaded, just used what the GRM came with installed. Than after I was having issues I saw mention of those SGR files on here (not on PleasantSims who I used first as a tutorial); So I did the GRM again afterwards once I got them from this forum site. (IDK should I have clean reinstalled the sims 2 in between using GRM?)

I added the DxDiag text file and some of the Sims2Exception and the AppErrors text files from the Log in Documents if that helps at all? I saw someone elsewhere mention those text files might help narrow down the issue.

Attached File(s)
.txt  DxDiag.txt (Size: 66.76 KB / Downloads: 236)
.txt  Sims2Exception 2021.12.15 02.56.20.txt (Size: 14.06 KB / Downloads: 217)
.txt  Sims2Exception 2021.12.15 03.15.30.txt (Size: 13.71 KB / Downloads: 191)
.txt  Sims2Exception 2021.12.15 03.39.31.txt (Size: 13.72 KB / Downloads: 205)

#4 15-12-2021 
  • Registered
  • 0
  • 3
Okay now I'm MORE frustrated. I saw someone in another thread mention that you should also ensure to apply the 4gb patch to the bodyshop's exe, and since CAS/CAF was causing the main error I thought okay I must have not done that and that's the problem.

But, Now the game won't even LOAD cause I'm getting the direct x 9.0c error even tho that wasn't happening before?! So now the game isn't even STARTING up and idk what I've done that caused the change??????? Do I just restart from scratch orz. This is so complicated I want to cry lol...

#5 16-12-2021 
It was good thinking to add some of the exception files, but most people here wouldn't know what to do with them anyway. I know I don't. So in future it's best to hold off on those until someone asks for them. Now as for the rest... I checked whatever seemed relevant in the DxDiag, and I see nothing out of the ordinary. The game not even starting anymore after patching the BodyShop, that really puts a damper on the fun. I don't even know where to start now, and hope that someone else has a solution. If not, though, there is indeed the option of uninstall and try again, but I would not do that yet, unless there is absolutely no other alternative anymore.

I'm incline to wonder if MrDJ's repack is entirely mcompatible with all the tinkering that is required of late to get the game running. On pre-win10 builds, it might have worked, but nowadays it's getting harder, even if you have the original setup-discs or Origin DL at your disposal.

#6 16-12-2021 
In your DxDiag I noticed this:
Page File: 9256MB used, 1716MB available (It also says you've got 8gb RAM)

Can you make sure your 'page' file is set to "system managed" (your on W10, right?)
And clear all the cache files (in your EA Games/saved game documents folder.)

Try it, and see if it starts. Good luck! Big Grin

If it still won't run... I'd suggest getting the UC (from and do a fresh install. UNINSTALL DJs version first!

#7 17-12-2021 
That link for OldGamesDownload is DJ's collection - this is why installing from there gives you a Mr DJ folder.

#8 17-12-2021 
Really? OK - so where is the link to the abandoned-ware UC?
(I use Origin, so I don't know?)

The link on SimsCave is also to the OldGamesDL:

#9 21-12-2021 
I too have the game on Origin, I'm not sure what the abandoned ware UC is but any download will do, the crashing isn't a result of that. Getting the RPC launcher and lowering texture memory will help.

#10 21-12-2021 
The UC one shared by osab on tumblr, which was taken down because EA filed a DMCA complaint. So I guess pirate at your own risk as EA apparently still cares?


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option