[solved] Unable to Open Game at All Without it Crashing
#1 06-01-2022 
  • Registered
  • 0
  • 1
Hi fellow simmers,

The Ultimate Collection (Games 4 The World version) won't even open for me, I just get a black screen and it crashes. To make sure this wasn't a user error with how I installed it, I got my hands on an old 2012ish era laptop and I'm able to get the UC downloaded and running (and even install CC). The only thing is that it's slow as heck and the screen has the tint of an old self-checkout machine. I know it's possible to get the Sims 2 running on my newer machine, it's just finding out what configuration settings need to be adjusted is driving me absolutely nuts.

Here's my specs:
  • Running Windows 10 on a 2019 MacBook Pro using Bootcamp
  • Processor: Intel® Core™ i7-9750H CPU @ 2.60GHz
  • Installed RAM:16.0 GB (15.9 GB usable)
  • System type:64-bit operating system, x64-based processor
  • AMD Radeon Pro 5300M

Things I have done:
  • Installed the 4GB patch (and made sure it was installed by following The Jessa Channel's instructions so it was installed correctly)
  • Installed the Graphics Rule Maker (on various settings)
  • Manually changed the resolution using the resolution fix per the instructions in the G4TW download file
  • Adjusted various compatibility settings in the application's properties (ex. changing the service pack, forcing the low display, etc)
  • Probably something else I'm forgetting

Nothing I have tried has worked. The game opens, there's a black screen (or my desktop shrinks to the top left and the rest is a black screen) for about a minute, then it crashes with the vague text box that says something like "this application has crashed and will now close."

I opened the latest exception file and it says:
Exception time: 01/05/2022, at 18+45.
Exception code: 0xC0000005 (-1073741819) ACCESS_VIOLATION.
Current thread ID: 1344 (0x00000540).
Version information:
Application/module path: C:\Program Files\The Sims 2 Ultimate Collection\Fun with Pets\SP9\CSBin\Sims2EP9.exe
Application/module version name: The Sims 2 EP9
Application/module version:
System version: Windows NT 6.0
System memory: 4096 Megabytes total, 4096 Megabytes free.
Application/module configuration: ReleaseSRT

Extra Exception Data:

Shutdown: 0
MemoryUsage: 3456408K
Neighborhood Name:
Neighborhood Prefix:
Lot Name:
Extra Exception Data End:

Exception module: C:\Windows\System32\DriverStore\FileRepository\u0348578.inf_amd64_c955a7a452d1bf20\B348746\amdxn32.dll.
Exception address: 0x71b46789. Section:Offset: 0x01:0x00045789.

Oh and I also cross-posted this on MTS, and the link is here: https://modthesims.info/showthread.php?p...ost5802273

Any and all help is appreciated!!

EDIT: oh & I attached my dxdiag.txt file if that helps identify the issue


EDIT 2: this has been solved! see: https://modthesims.info/showthread.php?t=663621

Attached File(s)
.txt  DESKTOP-UT1DSH0-config-log.txt (Size: 9.46 KB / Downloads: 198)
.rar  game files.rar (Size: 446.89 KB / Downloads: 204)
.txt  DxDiag.txt (Size: 84.53 KB / Downloads: 193)
(This post was last modified: 12-01-2022 10:30 PM by oleevia.)


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option