White screen while loading in windowed mode
#1 23-01-2022 
  • Registered
  • 1
  • 2
As of yesterday, I've been unable to properly load my Sims 2 UC game with RPC on my Windows 10 laptop with NVIDIA GeForce RTX 3070 Laptop GPU. Darn thing worked just fine a few weeks ago, but since then there's been an RPC update and some Windows updates. I had thought it was an RPC issue that I sent LazyDuchess a message about, but after googling the issue for a solution, it seems it may sincerely be a graphics card problem.

What I've done so far:

Tried new Graphics Rules.sgr and Video Cards.sgr
Uninstalled and re-installed graphics card driver using DDU
Playing in fullscreen mode, which is just black instead of white
Wished and prayed to the technical support gods

Edited to add a dxdiag.txt file to assist with troubleshooting!

Any help would be greatly appreciated it! Of course this would happen while I'm in the middle of testing several new bits of CC I've been working on after 5+ hours, lol.

Attached File(s) Thumbnail(s)

.txt  LAPTOP-CT51GBAE-config-log.txt (Size: 15.39 KB / Downloads: 228)
.txt  DxDiag.txt (Size: 122.07 KB / Downloads: 219)
(This post was last modified: 23-01-2022 11:07 PM by thechangeling.)

#2 24-01-2022 
Does it run without LD's stuff?

#3 24-01-2022 
Following your config-log, there are two graphics devices: 2x NVIDIA GeForce RTX 3070 Laptop GPU
But according to your DxDiag, you have 2x DisplayLink USB Device, 1x AMD Radeon ™ Graphics, AND 1x NVIDIA GeForce RTX 3070 Laptop GPU... that's FOUR Display devices?

I wouldn't have a clue how to help here. This is a nightmare to figure out!

#4 24-01-2022 
For one, you are forcing 15gb of texture memory when the card only has 8gb. Maybe try lowering that and starting the game without RPC.

#5 26-01-2022 
  • Registered
  • 1
  • 2
Thank you all so much for responding and helpin'! I work in IT, and unironically discovered the issue while fixing a client's GPU issue today, lol. Apparently, my docking station rig does not like to talk properly to my graphics card AT ALL. So it just behaves like it isn't there when my laptop is plugged into my docking station? It's heckin' strange that this is happening all of a sudden, but I suspect something in a recent update might have borked all of this, but it most definitely is not RPC! I just loaded the game perfectly on my laptop directly using RPC as if nothing happened, lol.

I haven't looked into this exactly, but I'm thinking a possible solution to using my dock and dual monitor setup is to mirror my laptop's display instead of just extending the screen onto the other monitors, and the laptop will need to stay open (even though I have it set to never sleep when the lid is closed). I'm currently battling a little cold, so I'll have to test this theory out at another time, but I can't tell you all how much I appreciate you looking into this for me! Hopefully this will be a help to the next poor soul that runs into this odd issue on a laptop/docking station/dual monitor setup?
(This post was last modified: 11-05-2022 03:17 AM by thechangeling.)

#6 29-01-2022 
So weird! Probably some odd, hidden thing windows set up to default GPU. Thanks for letting us know the issue, this could be helpful to others.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option