RTX 2060 - Windows 11
#1 02-06-2022 
  • Registered
  • 0
  • 3
Hi Guys,

I am running windows 11 on my laptop,

I have tried everything possible, but i cannot get the sims 2 UC to start

It just says the sims 2 mansion and stuff cannot start due to directx9.0c compatible card not found

I have tried running Graphics Rules maker,
I have tried manually adding my card to the list

Neither works

I am at a loss, can someone please help?

card 0x1f15 "GeForce RTX 2060"
card 0x1f15 "NVIDIA GeForce RTX 2060"

Attached File(s)
.txt  DESKTOP-0COKB9E-config-log.txt (Size: 10.61 KB / Downloads: 158)

#2 03-06-2022 
According to your log, you have an AMD card. Isn't the 2060 a NVIDIA card? I'm confused...
Do you know how to do a DXDiag? And can you post a copy of it?
(Just type dxdiag in your start menu search box, and hit save.)

You'll also need the 4Gb patch... but first things first. Wink

#3 03-06-2022 
  • Registered
  • 0
  • 3
I have been experimenting with both AMD and nvidia graphics, (laptop with both), I have attached the dxdiag below, I have also attached another log from (hopefully) when i forced via the nvidia control center it to launch using that gpu.

I tried both my built in graphics and the 2060 because as long as it works right?
I did patch a prior install with the 4gb patch, but i have also reinstalled incase there were missing files, i have tried using the june 2010 directx runtime installer as well just in case.

I am very eager to play sims 2 again, it was a highlight of my childhood. I will greatly appreciate any help you may or may not be able to provide


Attached File(s)
.txt  DxDiag.txt (Size: 109.67 KB / Downloads: 152)
.txt  DESKTOP-0COKB9E-config-log.txt (Size: 10.63 KB / Downloads: 165)

#4 03-06-2022 
OK. Your DXDiag says you have 2 GPUs:
AMD Radeon™ Graphics
NVIDIA GeForce RTX 2060

You need to choose which one you want to run TS2 (I would go with the NVIDIA, because that's what I use.) Wink
There should be a setting on your machine (for the life of me, I can't find it on mine right now *grrrrr*) but there should be a setting that lets you specify which card runs which application.
Once you've done that - set TS2 to use whichever card you choose. THEN run the GRM, with Admin control, and have it detect the right settings. Don't forget to hit 'save.' Have the GRM "add your card" if it needs to too.

While you're 'experimenting' getting your game set up, I would suggest NOT adding anything fancy (no CC, no reshade, no dvk-whatever...) Let's just get the game to start first.

Hopefully someone smarter than me will come along and help your further. Good luck!

#5 03-06-2022 
  • Registered
  • 0
  • 3
I have forced the settings in nvidia control panel to run the game only with the 2060, even in completeky stripped down mode it doesnt ever get past the directx 9.0c issue.

#6 05-06-2022 
You'll want to run the game in windowed mode. Add the -w switch to the shortcut in the Target field.


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option