flashing Purple/Black and Red/Black graphics issues, directx 9.0 error
#1 21-08-2022 
  • Registered
  • 0
  • 1

First off thank you and appreciate you for all the work you have done. I wish i had found your stuff a while ago. My original problem was the direct x 9.0c error. I have tried the 4 GB Patch and Graphics Rules Maker, and that did not fix the problem. I then found a fix that said to run it in window mode on the target path, which opened the game (In windowed mode), but now the sims maps landscapes are purple and black and when i go into a house it flashes red and black. I tried to do some of your updates on here for video and graphics cards and it has not helped. Lastly, i tried to update the config log but i cannot find my vendor card ID on the list. I would just like to run the game full screen and play it like i used to.

=== Graphics device info ===
Number: 0
Name (driver): Microsoft Basic Render Driver
Name (database): Microsoft Basic Render Driver <<NOT FOUND IN DATABASE!>>
Chipset: Vendor: 1414, Device: 008c, Board: 00000000, Chipset: 0000
Driver: d3d10warp.dll, Version: 10.0.19041.546, GUID: D7B71AF4-43CC-11CF-9261-616AAFC2C735
Driver version: 546

OS: Windows 10

Attached File(s)
.txt  DANIEL-config-log.txt (Size: 10.38 KB / Downloads: 154)
(This post was last modified: 21-08-2022 11:11 PM by deagleizer.)

#2 22-08-2022 
Hi @deagleizer,

Little tip beforehand: since you're attaching the config-log anyway, there was not really a need for you to also copy&paste part of it in your post.
It's not an infraction of any kind, and I'm not telling you off, just telling you that you did more work than you had to Smile

I'm seeing some issues, the most obvious of which, is the apparent lack of sufficient RAM. Now the config-log says that both your Total RAM and your Available RAM are at 2GB. This seems odd to me.
So I think we would be helped if you could please generate a new DxDiag.txt and attach a copy of that, so we can see what is really going RAM-wise.
Also, it seems like your game doesn't know about your GeForce graphics card. Maybe you need to run the latest version of GRM to include that card in the game's files.

Hoping to hear from you again,
~ BO


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option