Windows 10 and windowed mode
#1 28-05-2016 
  • Registered
  • 5
  • 5
Hello!
I'm in need of a little help. I'm trying to run the Ultimate Collection on a 64-bit Windows 10 (after using the fix in the Windows 10 and NVidia problems topic), I can get my game running without any crashes, only when it is in full screen.
When I try to play it in windowed mode, it throws an error: "Direct3D returned an error: E_INVALIDARG! The application will now terminate". I've already tried reinstalling Directx, but that doesn't fix the issue. My video card has been added to the database and I have changed the graphic rules file to one downloaded from here (more specifically 'Graphic Rules - NVIDIA - Texture Fix - Max Screen size 1920x1080').
Am I missing something? Or am I going to have to resort to playing in full screen?


Attached File(s)
.txt  DESKTOP-C65CPOS-config-log.txt (Size: 10.38 KB / Downloads: 28)
(This post was last modified: 28-05-2016 03:50 PM by Mulford.)

0
#2 29-05-2016 
Reading through the other topics in this section I think that for win10 its full screen only.

0
#3 29-05-2016 
My game runs in windowed mode on Windows 10. So it's not impossible. That said, I'm sorry but I don't know how to help you.

0
#4 30-05-2016 
  • Registered
  • 4
  • 5
Odd question but which graphics do you actually have? Since your log says this:
=== Graphics device info ===
Number: 0
Name (driver): NVIDIA GeForce 710M
Name (database): NVIDIA GeForce 820M

And I'm pretty sure those two should say the same thing. Just wondering if that might have something to do with your problem.

0
#5 31-05-2016 
  • Registered
  • 5
  • 5
I have the 710M, Digi.

This topic can be closed. I reverted back to windows 8.1 because windows ten basically took my laptop to hell. Still having graphics issues (namely that it won't run on Nvidia no matter how I try) though not the ones in the topic
(This post was last modified: 31-05-2016 09:35 PM by Mulford.)

1
#6 01-06-2016 
@Mulford

When you say that it won't run NVidia - is it using the NVidia and crashing? Or is it always using the Intel card?

With NVidia, you're going to need to back out the driver changes from Windows 10, going back to 8.1 and manually add them back in again because NVidia is f*cked on Windows 10 auto updates. That may fix your NVidia problem.

1
#7 01-06-2016 
  • Registered
  • 5
  • 5
It is always using the Intel card, even if I force it to run with the Nvidia.

Back out the driver changes? Do you mean uninstall the driver and then manually reinstall?

1
#8 01-06-2016 
OK. I wouldn't bother doing any changes to the NVidia card then. If it's always using the Intel, and you've got the game set up for the Intel it should be fine as is.

1
#9 01-06-2016 
  • Registered
  • 5
  • 5
Update: I had to uninstall the driver and installed an older version. Sims 2 works like a charm with my Nvidia card now. Thank you for the help!

2

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option