Sims 2 UC crashes on splash screen
#1 14-06-2016 
  • Registered
  • 1
  • 3
Hi! I've been trying to make TS2 UC work for like two weeks now, I'm kind of hopeless. I just got a new laptop with Windows 10 and none of the available solutions work. Every time the game freezes on either "Over Waxing Banisters" or "Making Manic Mansions". I ctrl-alt-del my way out of it then it crashes. No matter what I do. So far I have tried the following:
-Ran the game in compatibility mode (it only made things worse. The game refused to start and I had to uninstall it)
-Set affinity to one core
-Uninstalled and reinstalled it 3 times so I could have a fresh canvas
-Installed Nvidia graphics fix
-Removed SecuROM completely and used a no-cd exe
-Ran the game in administrator mode
I think that's all. It works perfectly on my old Windows 8.1 laptop though. It's pretty darn frustrating. Any help is welcome. Thanks Smile

.txt  DESKTOP-LS4C398-config-log.txt (Size: 10.35 KB / Downloads: 38)

EDIT: I discovered the problem. The game only runs with Intel. Any way I can make it work with the Nvidia chip?
(This post was last modified: 14-06-2016 03:30 PM by julie31.)

0
#2 04-07-2016 
@julie31

If you can pop it back to the NVidia card, and install this card as well as the graphic rules fix for NVidia -

Video Cards.sgr - NVIDIA - 13d7

\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\Config\
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\CsConfig\
MUST BE INSTALLED IN BOTH FOLDERS

That *should* fix your problem. If it doesn't upload a new config-log.txt for me to have a look at.

1
#3 26-07-2016 
  • Registered
  • 1
  • 3
@celebkiriedhel Shoot. That link isn't available :-(
(This post was last modified: 26-07-2016 10:14 PM by julie31.)

0
#4 27-07-2016 
Oh so sorry - I forgot to check the link. (Spelling mistake). The link works now.

0
#5 27-07-2016 
  • Registered
  • 1
  • 3
@celebkiriedhel Thank you, the link is working now. Pasted the file in both folders. It still freezed and crashed afterwards at the "Over Waxing Banisters" line. I've also noticed that if I run the game using the nvidia chip it loads so slow! This game really hates my card I guess, haha. I'm going to attach a new log. Smile
.txt  DESKTOP-LS4C398-config-log.txt (Size: 10.35 KB / Downloads: 23)

1
#6 28-07-2016 
@julie31

Hmmm.... it sounds like NVidia really doesn't want to play with Sims 2.
You've done the removing securom which normally does the lag, and your CPU isn't too fast to cause lag. You've got plenty of RAM and memory for everything.

So to be honest? I'd install the Intel Graphics fixes and use the intel card. The graphics on that will be very comparable to the NVidia.

If you want to persist with the NVidia, your next step is to go to this thread and try the NVidia fixes which are stuffed up because of Windows 10.

Windows 10 and NVidia Problems

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option