Ultimate Collection very slow on Windows 10
#1 05-07-2016 
  • Registered
  • 6
  • 8
Hey there,

I have been having issues recently with the sims 2 on my PC. The game is very laggy, especially when switching between sims in my household or in build/buy mode. I have tried some of the fixes shown on this site with no success so far. I am at a loss as to what to do. I have heard that I could download a no CD crack but I i'm very weary of doing that. Any help would be greatly appreciated. Smile

Here is my -config-log.txt

.txt  MATTHEWSPC-config-log.txt (Size: 10.3 KB / Downloads: 37)

0
#2 05-07-2016 
Hi @Mattgstl,

I can imagine that your system is slow and laggy: according to the config-log, it has only 1GB of memory! Running The Sims 2 under Windows 10 is asking way too much of that poor old machine. Your processor might be up to the task, but the rest of your system is not. I'm afraid I would suggest getting rid of Windows 10, and installing Windows XP (SP2) instead. That would make your sims game run a lot better. What would really help, though, is a computer with more system memory.

Forget that nonsense... I'm obviously mistaken.

0
#3 06-07-2016 
@BoilingOil

The Graphic rules is not accurate with the Memory. (So for example I've got 16G of RAM but my config-log says 1024Mb). You can tell that they've got more than 1G because both the memory and the free memory say 1G. In the other thread where I said they didn't have enough memory their free memory was 504Mb, and the specs of the computer said that it only had 1G of Ram. So yeah - thanks, but you're not correct here.

@Mattgstl

Your machine is fine. We can make some differences for you, but we'll do them in stages.
First up, We need to correct your graphic rules and video cards.sgr first. That will make a difference.

Download these files:
Graphic Rules - NVIDIA - Texture Fix - Max Screen size 1920x1080
Video Cards.sgr - NVIDIA - 11c4

Into these folders:
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\Config\
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\CsConfig\
MUST BE INSTALLED IN BOTH FOLDERS

That will fix your graphic rules, and video cards.sgr and give you better resolution. Once you've done that, please go back into the game, then come out, and upload the new config-log.txt.

0
#4 06-07-2016 
  • Registered
  • 6
  • 8
@celebkiriedhel

I have installed the two files in the locations and here is my new config-log


.txt  MATTHEWSPC-config-log.txt (Size: 10.37 KB / Downloads: 21)

1
#5 07-07-2016 
  • Registered
  • 6
  • 8
hi again,

I have been doing some searching around on these forums and I found a thread which had details of how to remove securom and add a no CD crack. This would apparently fix my problem. I followed these steps with the link to the crack provided and whenever I try and load a neighbourhood the screen goes black and I can't interact with anything. Am I doing something wrong??
I did make a backup before deleting the old application thankfully!!

1
#6 11-07-2016 
@Mattgstl

You also need to do the stuff in this thread first, because the NVidia drivers set up by the Automatic update are incorrect.

Windows 10 and NVidia Problems

Removing Securom and using the no-cd crack will fix the lagging due to the securom, but it won't fix the problems with the NVidia drivers.

0
#7 11-07-2016 
  • Registered
  • 6
  • 8
@celebkiriedhel

I haven't had any issues with my drivers in the past? I will follow your advice and will come back if all went well.

1
#8 16-07-2016 
  • Registered
  • 6
  • 8
@celebkiriedhel

Sorry for no reply's I have been away for a while. I have followed what you said in the previous post.


.txt  MATTHEWSPC-config-log.txt (Size: 10.27 KB / Downloads: 18)

0
#9 17-07-2016 
@Mattgstl

Your config log says that you installed the Video Cards.sgr, but not the graphic rules.

You need to install the graphic rules as well.

0
#10 17-07-2016 
(07-07-2016 07:02 PM)Mattgstl Wrote:  hi again,

I have been doing some searching around on these forums and I found a thread which had details of how to remove securom and add a no CD crack. This would apparently fix my problem. I followed these steps with the link to the crack provided and whenever I try and load a neighbourhood the screen goes black and I can't interact with anything. Am I doing something wrong??
I did make a backup before deleting the old application thankfully!!

Removing securom will fix the lag. The hood screen does go black but setting the games compatibility to Windows 7 should fix it. Smile

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option