Sims 2 UC Crash - Application Has Terminated
#1 04-08-2016 
  • Registered
  • 0
  • 3
I continually get this error when I try and run Sims 2 UC! I already applied all the graphic fixes, and it solved most everything except the windowed mode BS. This error, though, won't go away. It always crashes during the main loading screen, right after the intro. Here is the Exception File, and Config-Log.

.txt  Sims2Exception 2016.08.04 17.41.59.txt (Size: 13.75 KB / Downloads: 508)

.txt  VEE-PC-config-log.txt (Size: 10.41 KB / Downloads: 448)

#2 05-08-2016 

Eep! Well according to the config-log.txt your graphic requirements are set up correctly, so that's not the problem.

Do you have any CC in the game? If you do, there could be a CC problem.

1. First try deleting the caches. Sometimes they are corrupt.

If you go to
\Documents\EA Games\The Sims 2\

You'll see files with a ".cache" suffix. Delete them and then try and run it again.

Does it work after doing this? Yes - go to this thread: Tutorial - Clearing the Caches for how to make this problem go away forever.


Step 2:

Do you have CC in your game? Test the game without CC - if it crashes without CC, then we can rule out the CC problem.
If it doesn't crash without CC, then youi have some corrupt CC.

What you will need to do is use the 50/50 method of determining what it is.
50/50 method.

1. Divide your Downloads into two groups - A and B.
2. Put A into your game, B outside of your game.
3.Does the game load? Yes - A is ok. Put those into a Save folder outside of the game.
No. B is OK. Put B into a Save folder outside of the game.
4. Whichever is your remaining half, go back to Step 1 and do it again, but only on the half that doesn't work.
5. Repeat steps 1-4 until you have just one package. That is your corrupt one. Take it out.
6. Put everything else back into your game and check that it loads. Yes? You're finished. No? Start again at Step 1 with the remaining downloads until you've found the next corrupt content.

Step 3: Does it crash without any CC in game?

Come back here, and we'll see where we can go next.

#3 04-09-2016 
  • Registered
  • 0
  • 3
Every time I try Sims 2 UC it's a new problem. It refuses to run with my NVIDIA card now, doing the INVALID_ARG Direct3D error again. The config log is the same.
I swear, it was at least getting into the game before. I don't have any CC, and reinstalling Sims UC is almost impossible with the condition of my internet.

I tried using Intel, which works fine, but no matter what I do to the damn thing, it won't use anti-aliasing or any smooth edges. It looks atrocious.
And the Intel option has been completely fixed to include anti-aliasing in every csg point where it's even brought up!
The config-log even says it's on! The edges of water are still blocks.

Here's my Intel Config-Log.

.txt  VEE-PC-config-log.txt (Size: 10.38 KB / Downloads: 428)

And a pic of the ugly bastard.

.bmp  Screenshot.bmp (Size: 468.8 KB / Downloads: 469)

Ugh, it put the wrong config in there. Sorry about that. I'll put the right one here.

.txt  VEE-PC-config-log.txt (Size: 10.48 KB / Downloads: 431)
(This post was last modified: 04-09-2016 07:46 PM by veepersjeepers.)

#4 04-09-2016 
Yeah I saw this problem with MDP's config-log. It was quite a doozy - and eventually she worked out what the problem was.

To fix it, I need to make up a new INTEL graphics card for you. (it's 6am here and I'm about to go back to bed) - but I will do it today my time.

Then we can test it out and see if we can make it go.

#5 07-09-2016 
  • Registered
  • 0
  • 3
Thanks so much!


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option