Black screen with Windows 10 & Discs
#1 15-03-2017 
Kiri and I both knew I'd turn up here sometime Blush

I'm experiencing the same problem as beccajuster here. Once I've reached neighborhood view, the screen goes black. I can limp my way around like this: hit the Windows Key to open the taskbar, click the ts2 icon there, game opens again and I can see what I expect to see, but once I mouse-click on anything in game the screen goes black again. Google hits for "Black Screen Sims 2" are mostly about Windows 8 and the solution seems to be "stop using Windows 8"
Before editing any .sgr files, my game didn't have the black screen but it also didn't have smooth edges / looked bad and my only screen resolution choice was 800x600
New computer:
CybertronPC - Rhodium R7 Desktop - AMD FX-Series - 16GB Memory - AMD Radeon R7 360 - 2TB Hard Drive

I installed from discs and patched what I could but I think The Best Of discs I have are already patched
I removed Securom and the no-cd crack for M&G seems to be working
Target: "C:\Program Files (x86)\EA GAMES\The Sims 2 Fun with Pets Collection\SP9\TSBin\Sims2Launcher.exe" -CPUCount:1
I dl'd Kiri's Graphic Rules - RADEON - Texture Fix and edited the screen resolution in that file
I've cleared caches and I'm running the game as administrator

The good news:
- smooth edges are enabled
- correct screen resolution
- sims have nice shadows thanks to Nopke
- According to my config-log, I edited the Video Cards.sgr correctly

Any help is greatly appreciated - thank you! Heart

Attached File(s)
.txt  DESKTOP-6MC4TMB-config-log.txt (Size: 10.2 KB / Downloads: 114)
shastakiss, proud to be a member of LeeFish since Apr 2012.

1
#2 16-03-2017 
@shastakiss

Hey Petal! Can you do me a dxdiag.txt as well? You've done all the bits and pieces correctly (not unsurprisingly).

Windows Button + R will bring up the Run Window
DXDiag + enter will bring up DXDiag window
"Save all information" will create a dxdiag.txt as well.

Are you running the game in Windowed mode or Full Screen?

1
#3 16-03-2017 
Full screen! I tried running in Windows but it was even harder to limp around. Ideally I'd like to play full-screen anyhow.
Thank you for your help! Smile

Attached File(s)
.txt  DxDiag.txt (Size: 75.16 KB / Downloads: 151)

0
#4 17-03-2017 
@shastakiss

There's a known problem that we haven't been able to fix as yet regarding full screen/windowed where it works in one but not in the other. If this problem is that one - I don't know how to fix it. However I will do my best.

What's your screen resolution on your native screen - i.e. outside of the game, and what's your screen resolution in game?

In the meantime - here's a little tweak that will make things go like the clappers texture wise - Graphic Rules - Radeon - Shasta Display Memory (You have a wopping great Display Memory: 10190 MB - if you ever get pink flashing I will be Sooooo surprised).

Pop it in the same place you put the graphic rules before.

When you say limped around when in windowed mode - what exactly do you mean?

1
#5 17-03-2017 
Hello, just popping in to say that whenever I have had the black neighbourhood screen problem, setting compatibility to windows 7 fixes it (either by using the compatibility tab on the shortcut properties or by selecting trouble compatibility and choosing it worked in a previous version). Hopefully this helps you!

2
#6 17-03-2017 
@TheDarkLady Thanks! We will try that!

1
#7 18-03-2017 
I am this close to mushy happy tears! Heart My game is RUNNING BEAUTIFULLY Celebrate

First of all, thank you very much for the customized Graphic Rules file, Kiri Smile I love how smart you are about computers you don't even own!
And in answer to your question, I honestly didn't realize my native screen resolution could be / should be different from my game's but it's 1920x1080.

I added the "-W" back in to the Target and couldn't do anything so I must have misremembered being able to navigate a little (aka limp) with the black screen in windowed mode.
Thanks to TheDarkLady's tip, I looked under Properties' Compatibility tab and saw it was already running in Windows XP (Service Pack 2) Compatibility Mode!? Y'all I'm sorry if it's second nature for an experienced PC user to check that, I just didn't know. I unticked that and now I'm a big puddle looking at my pretty game Blush

Thank you @celebkiriedhel and @TheDarkLady for your help - I am all to pieces and very grateful!

2
#8 20-03-2017 
Fabulous!!

0
#9 16-09-2017 
  • Registered
  • 0
  • 1
Actually I'm having this same problem except for one thing, I go into the properties for the game and fsr the compatabilities tab is no longer there...? I'm like really confused as to what could be going on tbh.

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option