Sims 2 Ultimate is Flickering (windows 10)
#1 01-08-2017 
  • Registered
  • 0
  • 2
Hello! first time posting! I hope this is the right place.

I recently started playing the sims 2 on my laptop and the game keeps flickering just when I was finally able to run it without lag.
I'm on windows 10, I've tried running it on compatibility but nothing changes. I was reading previous threads and I changed it to run as admin but idk what else to do.

My pc specs:
Windows 10 64bit
Processor: Intel Core i7-5500 CPU 2.4Ghz
Ram: 12GB
Graphics Card: AMD R7 M265 Series

Quick side note: I read that I'm suppose to change the smooth edges settings but both shadow and smooth edges settings are grey out

Attached File(s)
.txt  AURICHU-config-log.txt (Size: 10.49 KB / Downloads: 32)

0
#2 05-08-2017 
You need the right Graphics rules. You can get it on this website, but I'm not sure where it's at. Someone will be by shortly to advise you, help you get it straightened out.

0
#3 05-08-2017 
  • Registered
  • 0
  • 2
Thank you! it turned out that I was using the wrong graphics rule file.

0
#4 08-11-2017 
  • Registered
  • 2
  • 2
I tried to use the graphic that was posted here on the website but I am still unable to play sims 1 without the flickering and glitches. Also I can not slide up the shadows because it is greyed out. Please someone help me! I attached my graphics rule file! Thanks!

Attached File(s)
.docx  Logging settings.docx (Size: 20.65 KB / Downloads: 14)
(This post was last modified: 08-11-2017 01:49 AM by 0C47399WT.)

1
#5 08-11-2017 
@0C47399WT

I'm not able to read docx files. Please upload it as a config-log.txt file.

0
#6 08-11-2017 
I *can* read it (in Wordpad); that file has got nothing to do with the config-log.txt ...

1
#7 08-11-2017 
  • Registered
  • 2
  • 2
@celebkiriedhel @BoilingOil Sorry, here is the config log text. I hope this one is correct.
.txt  SHIVANAND-config-log.txt (Size: 10.41 KB / Downloads: 13)
(This post was last modified: 08-11-2017 07:14 PM by 0C47399WT.)

1
#8 09-11-2017 
@0C47399WT Yes it is.

1. I see that you have the 32MB Texture memory bug. Kiri knows much better than I how to fix that.

2. It seems that the game is using built-in graphics, not the AMD graphics card. I would like to see what the config-log.txt looks like if you were successful in selecting the AMD card for your game graphics.

0
#9 11-11-2017 
@0C47399WT

Download these cards:

Graphic Rules - INTEL - Texture Fix
Video Cards.sgr - INTEL - 1616

and install them into the Program folders:

If you have the CD/DVDs -

\Program Files (x86)\EA\The Sims 2 - <your most current expansion pack>\TSData\Res\Config\
\Program Files (x86)\EA\The Sims 2 - <your most current expansion pack>\TSData\Res\CSConfig\
MUST BE INSTALLED IN BOTH FOLDERS

Note: If you have a deluxe edition or so on - look for the expansion that has EP99 - that is the one you'll need to use.

If you have Ultimate Collection -

\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\Config\
\Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\CsConfig\
MUST BE INSTALLED IN BOTH FOLDERS


If you manage to get the Radeon card working, you will need different cards, so let me know if that happens, and I will link you to the right ones.

0

Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.


Sorry, that is a members only option