The Sims 2 Ultimate Collection Windows 10 Crash Fix (March 2018)
#1 22-03-2018 
  • Registered
  • 2
  • 4
Hello everyone.

Forgive me if this is not the correct place, but after digging through the internet and connecting with other simmers, I've finally found a fix to the cursed crash issue with Windows 10 and its horrible operating system. As we all knew, hundreds of people around the world have been experiencing the issue and as we hoped it was only a matter of time before we found the fix. A thread over at the Sims official site sparked some conversation with me and a few others. Anyway, this is what we did:

Memory Leak Fix
Again, thank you so much to the friends over at The Sims Forum! Check this video out for Windows 10 memory fix. I did it once and have never crashed since. I've tried EVERYTHING and nothing would work... including all of the pages on this site. Anyway, watch the video and follow the instructions.

https://www.youtube.com/watch?v=7_yv-sZxub4 (new for March 2018)

Set Groups and Accessories cache to Read Only
Some of you may have heard of this (this site has directions on it), but it certainly makes the game faster/has stopped me from having to continually delete my cache/reduced stress on the game which leads to crashing in the first place.
1. Download the Accessories cache from here
Download the Groups cache from here
2. Place them both inside of your The Sims 2 Ultimate Collection folder after deleting the ones already there.
3. Right click on them the Accessories cache.
4. Go to Properties.
5. Scroll down to Attributes.
6. Check Read Only.

Please give me feedback and let me know what worked/didn't work for you!

Bonus you might try
Try Razer Cortex: Game Booster. It optimizes use computer so that most of its focus is pointed toward the game play. I have thousands of files of CC and it has reduced loading screens and my game runs beautifully. I always open the game through this application because Windows 10 is a fraudulent and sneaky evil operating system which runs COUNTLESS applications in the back of your computer and unlike Windows 7 is very good at concealing them, even when you think you've found and removed them all. Most of the systems running in secrecy are meant to record your internet access usage and report data to a data collecting agency (for more information do your research; they aren't shy about this. I hate Windows 10 but I am stuck with it. Microsoft is full of creeps and criminals. Big Grin)

ANYWAY

1. Open the application.
2. Go to Game Booster at the top.
3. In the center option is Boost. Go ahead and click the green box.
4. Once its done, go to Games option at the top and add the Sims 2 Ultimate Collection and or Body Shop if you want (makes it appear MUCH faster.)
5. Play the Sims 2 Ultimate Collection through the booster.
6. Have fun.

1
#2 24-03-2018 
Thank you so so much for this! Does this by any chance fix the pink flashing as well as the crashing? I've yet to try any of this but I'll definitely be sure to.

0
#3 03-04-2018 
  • Registered
  • 2
  • 4
Sorry for the late reply! Yes, this should certainly fix the pink issue. ALSO mix and max the options above for the best function for your computer. I personally dont use the downloaded caches, but some do!

0
#4 09-06-2018 
  • Registered
  • 0
  • 3
As for the Razer Cortex... is there any way to play the game in windowed mode through it?

0
#5 13-06-2018 
  • Registered
  • 0
  • 1
You can play in windowed mode through Razer Cortex if you add -w in the Launch parameters box.

Go to games --> click on view dashboard of your Sims game --> edit game by clicking on the cogwheel --> add -w in the Launch 'parameters box'.

0
#6 24-07-2018 
  • Registered
  • 0
  • 3
Hey there!

I tired all the steps and I have to say its a huge improvement with the other steps I have read about online!
However. I am still encountering multiple crashes and the dreaded pink flashes? Any thoughts?

I am guessing that the Razer Booster is helping yet there is still something happening that is causing the game to crash! Would putting it in windowed mode help at all?

Attached File(s)
.txt  Sims2Exception 2018.07.24 21.49.52.txt (Size: 15.01 KB / Downloads: 16)
(This post was last modified: 24-07-2018 01:03 PM by Spazattude.)

0
#7 10-08-2018 
  • Registered
  • 0
  • 1
Hi
Ok newbie so please excuse any wrong doing.

With the pink flashes open your cheat window on your pc.(ctr-shift-c)
Type " boolprop testingcheatsenabled true" and enter
Then type " boolprop useshaders false" and enter

If you roads,treas,cars ect turn to white just enter the useshaders cheat again but instead of false say true.

And... problem fixed!!! Althou this is a fix that you have to enter everytime you restart your game. Hope this helps

But now I need help. My build objects appear red and in live mode the flash red. The flashing only seems to be on : pools ect , walls, grass windows and doors, roof. Any idea how I can fix this?

Almost forgot the " boolprop useshaders true/false" also works when your sims appear red with arms sticking out sideways. First enter "false" if it doesnt work enter the cheat again but say " true"
eg: boolprop useshaders true
boolprop useshaders false

Other helpfull cheats for graphics

boolprop bumpmapping true/false
vsync on/off
boolprop objectshadows on/off
boolprop guob on/off

Sometimes turning off the shadows helps. All the above only work when "boolprop testingcheatsenabled true" is on.
(This post was last modified: 10-08-2018 12:36 AM by Soritha.)

0


Sorry, that is a members only option