Sims 2 UC Apartment life bug
#1 21-02-2021 
  • Registered
  • 0
  • 1

I tried to find a similar question/bug which has already been solved or talked about, but because my English is not my default language, it is a bit hard for me to find a/the solution between all the threads on this forum. I'm Dutch and LEEFISH is a .nl website, so maybe it can be in Dutch? But if the problem I'm experiencing is comment and we can help other people out in the future finding the solution for this, then English is fine (and of course if you do understand my bad English).

I have The Sims 2 Ultimate Collection from Origin, running on Windows 10. Before Windows 10, I had Windows 7.

These are the 2 things I did to run The Sims 2 correctly:
I used this tutorial to get the right resolution:
After that the resolution was fine, but the game was still very, very slow.

I fixed that doing one of the things from this link:
I downloaded these 2 files:
× Graphic Rules - NVIDIA - Texture Fix - Max Screen size 1920x1080
× Video Cards.sgr - NVIDIA - 11c4

And installed them both here:
× \Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\Config\
× \Program Files (x86)\Origin Games\Fun with Pets\SP9\TSData\Res\CsConfig\

Doing that fixed my problem and my game is as fast as it has to be. (Thank you so much!)

Everything seemed to be working, except for one thing.
I said "Everything", but I did not try literally everything in the game. Didn't go on a holiday, go to a mall, I didn't even spent 24 hour in a house with my family. So maybe there are more bugs than the one I'm opening this thread for and I'm reaching help for.
But making a family, buying a house, put some stuff in it, go to work, play, everything seems to be working fine.

Here is the problem: I wanted to live in an apartment.
I put the apartment-base with the caravans in the neighborhood, created a family (man, woman, cat) and move into the caravan-base.
Everything works: My people talk to each other, they pet their cat, say Hi to the apartment-host (or whatever the name is of that man/woman), ...
But when I click on a apartment on the 'rent this apartment'-button, the game shut down after 2 seconds (literally).
And the craziest thing about it, is that I tried it over and over, and everything works fine, but whatever I do, right on the moment I click on the 'rent this apartment'-button, the complete game shuts down. 2 times (out of 7?) I got a message that the game had a bug or something and had to shut off, but the other times, not even a message, just shutting off.

Is this a comment thing for The Sims 2 UC - Windows 10?
Does anyone has the same issue? Or maybe there is a solution for this?

I tried to repair the game twice on Origin.
I also did the right-click - Compatibility-thing and set it to Windows 7, which I had before, but that didn't work. Also set it to Windows 8 to try but that didn't work either.

I am so sorry if the solution for this was right before my eyes on this forum and that I've missed it. I hope in that case the link can be sent to me!

Thanks for reading. So much information, but I'd rather give all the information I have (including things I've tried so solve the problem) than give you nothing but "My game doesn't work".

Greets, Hysteriaa

Attached File(s)
.txt  SABLE-config-log.txt (Size: 10.34 KB / Downloads: 288)

#2 21-02-2021 
(21-02-2021 01:46 AM)Hysteriaa Wrote:  I'm Dutch and LEEFISH is a .nl website, so maybe it can be in Dutch?

I'm afraid not. If the site were in the Dutch language, the audience would be mostly limited to only Dutch people. This site only works so well because it's in English. Besides, the site may be based in the Netherlands, because the owner - Leefish - lives here, but she is of British origin; her native language is English.
Besides, did you know that the very well-known English-spoken site ModTheSims is ALSO actually based in the Netherlands? It just doesn't show, because they use a .info instead of a .nl region.

But don't you worry about not being able to find a similar problem, because you think your English isn't good enough. I'm Dutch too, and I'm often told that my English is excellent, but I usually cannot find anything either. Anyway, we're not getting cruel like other sites, just because you start a thread about something that was already answered. If we know the answer, we may offer you a link to the other thread, or simply answer the question again. No problem! Don't worry about it.

Someone will try to help you soon enough.

#3 21-02-2021 
Could you please provide a dxdiag report? You said you used the Nvidia graphics rules/video cards file, but you have a radeon graphics card according to your config log so we need to see which you've actually got. You also haven't applied the 4GB patch, which will prevent crashes. Make sure that you never run in compatibility mode because that will prevent the patch from working and you will then have to reapply it. Here is a link to Kiri's tumblr which has the exe "George" - it has the 4GB patch already applied, and it will also stop Origin from being needed for the game to run. It would be better if you used George than manually patching so that Origin is no longer involved in running your game.

#4 21-02-2021 
Yes! What she said ^^^
Once you get your game working - NEVER 'repair' from Origin. If you do, you will have to do everything over again to get your game working.
Use 'George', and forget that Origin exists Smile


Before you post requesting help
Information we need

  1. The -config-log.txt from the Logs folder in the My Documents\EA\The Sims2\ Click "full editor" below to attach a text file.
  2. Your operating System.
  3. What the problem actually is - that will be a picture to show the problem (optional), and accompanying text files that turn up (optional), and a detailed description of what happened, and what you expected to happen.

Sorry, that is a members only option